Analyze Menu

From Audacity Manual

Jump to: navigation, search

Menú Analizar

The Analyze Menu contains tools for finding out about the characteristics of your audio, or labeling key features. Plug-ins that accept audio input but produce no audio output will be placed in the Analyze menu, with the analysis results being provided by labels (or in some optional LADSPA plug-ins by an "Effect Output" section in the plug-in itself).

Although by default, no keyboard shortcuts are provided for most of the analysis tools, it is possible to set up your own shortcut for any Analyze command. For instructions on how to do this please see Keyboard Preferences.

  • Many of the analysis tools shipped in Audacity are Nyquist plug-ins which can be edited in any text editor. See Nyquist Plug-ins Reference on our Wiki for more details about the Nyquist format. You can download additional Nyquist analysis plug-ins. The built-in analyzers are LADSPA effects. Some additional LADSPA analysis plug-ins for Linux can be downloaded from
  • The description page for each shipped analysis effect (accessed by the links below) shows an image of the interface and its default settings.

Audacity's Analysis Tools

Add / Remove Plug-ins...

Selecting this option from the Analyze Menu (or the Effect Menu or Generate Menu) takes you to a dialog which enables you to load and unload Analyzers (and Effects and Generators) from Audacity. This enables you to customize your Analyze Menu making it shorter or longer as required. For details see Plug-in Manager: Effects, Generators and Analyzers.

Additional plug-ins can also be loaded into Audacity. For details see the following FAQs:

See also this list of available Nyquist analyzer plug-ins on the Audacity Wiki, that you can easily download and add to Audacity.

Built-in LADSPA analysis tools

Contrast...  CTRL + SHIFT + T

Analyzes a selected, single non-stereo audio track to determine the average rms difference in volume (contrast) between foreground (the speech) and background (music, audience noise or similar). The purpose is to determine if the speech will be intelligible to the hard of hearing.

Plot Spectrum...

Takes the selected audio (which is a set of sound pressure values at points in time) and converts it to a graph of frequencies (the horizontal scale in Hz) against amplitudes (the vertical scale in dB).

Find Clipping...

Displays runs of clipped samples in a Label Track, as a screen-reader accessible alternative to View > Show Clipping. A run must include at least one clipped sample, but may include unclipped samples too.

Nyquist Plug-in analysis tools shipped with Audacity

Beat Finder...

Attempts to place labels at beats which are much louder than the surrounding audio. It's a fairly rough and ready tool, and won't necessarily work well on a typical modern pop music track with compressed dynamic range.

Regular Interval Labels...

Places labels in a long track so as to divide it into smaller, equally sized segments. For example, this can be useful for distributing a large file on the internet. You can either choose the number of labels to be created, or the interval between them. Each label produced contains the chosen label text.

Sample Data Export...

Reads the values of successive samples from the selected audio and prints this data to a plain text, CSV or HTML file.

The following two related "Silence Finder" and "Sound Finder" tools are very useful to label the different songs or sections in a long recording, such as the tracks from an LP or cassette.

Silence Finder...

Divides a track up by placing point labels inside areas of silence. Use this if you just want to split the recording into tracks at a specific point without removing the silences between them.

Sound Finder...

Divides a track up by placing region labels for areas of sound that are separated by silence. Use this to make the labels show the exact region of each track to be exported. This lets you remove some or all of the silence between the tracks.

To add a new Nyquist plug-in, put it in the Audacity "Plug-Ins" folder.
  • On Windows and OS X the "Plug-Ins" folder is in the directory where Audacity resides - usually C:\Program Files or C:\Program Files (x86) on Windows or the "Applications" folder on OS X.
  • On Linux, the "plug-ins" folder is in usr/share/audacity if you installed an Audacity package supplied by your distribution, or usr/local/share/audacity if you compiled Audacity from source code. Optionally a "plug-ins" folder can be created in the home directory thus: ~/.audacity-files/plug-ins (you can also call the folder "plugins").

To load the new effects into Audacity so they are available in the menu, use the Plug-in Manager: Effects, Generators and Analyzers dialog.

Vamp Analysis Plug-ins

You can also add some additional analysis tools in the Vamp plug-in format for viewing and analysing the descriptive contents of music audio files. Typical things that a Vamp plug-in might calculate include the locations of moments such as note onset times and power or fundamental frequency data.

To run a Vamp plug-in, select the audio and run the plug-in from the menu. An annotated label track appears showing the result. At this time, Audacity cannot display graphical output such as histograms or curves.

Warning icon Currently Audacity cannot load Vamp plug-ins from the Audacity "Plug-Ins" folder.

Vamp plug-ins are loaded from the following standard directories each time you launch Audacity:

  • On all platforms: any directories listed in the VAMP_PATH environment variable
  • additionally on Windows:
    • %%PROGRAMFILES%%\Vamp Plug-ins (a directory named "Vamp Plug-ins" within the system Program Files directory, however localized and on whatever drive is relevant to this install of Windows)
  • additionally on OS X:
    • ~/Library/Audio/Plug-Ins/Vamp (user plug-ins)
    • /Library/Audio/Plug-Ins/Vamp (system-wide plug-ins)
  • additionally on Linux/Unix:
    • $HOME/vamp
    • $HOME/.vamp
    • /usr/local/lib/vamp (user plug-ins)
    • /usr/lib/vamp (system-wide plug-ins).
Personal tools