Keyboard Shortcut Reference

From Audacity Manual

Jump to: navigation, search

Tipkovni prečaci Referencia de atajos del teclado

Ed 10May12 I'm a bit confused by having the "same" command(s) in two sections. Look in the Edit table and see:

"Cursor Short Jump Left(1) , Moves the cursor one second left."
Look in the Transport table and see:
"Short Seek Left during Playback(1) LEFT or , Skips the playback cursor back one second."
Are these in fact the same command with different names? Note the first footnote:
"(1) The long and short jump times can be set in the Seek Time When Playing section of Playback Preferences."
(to the Edit table) and the second footnote:
"(1) The long and short seek times can be set in the Seek Time When Playing section of Playback Preferences."
(to the Transport table) are almost identically worded but also note the there is no "jump time" setting in Prefs.

  • Gale 08May13: I've tweaked the first footnote of the two you cite.

Note that "Short Seek Left during Playback" shows two possible shortcuts: LEFT or , (comma); and that "Cursor Short Jump Left" only lists one: , (comma). Is this accurate?

  • Gale 08May13: Yes. LEFT and RIGHT nudge the cursor by one pixel when playback is stopped.

on a tangentially related note, given the visual nature of HTML, would it be better to not reuse footnote numbers on a page (we have three footnote (1)s on this one).

  • Gale 08May13: They are separate tables so I think it would look equally odd if the footnotes had separate numbers.

This page provides a list of all keyboard shortcuts that can be used in Audacity, arranged in similar functional groupings used by the Menu Bar and Toolbars.

  • Some shortcuts do not have an equivalent menu item. In the tables below, these shortcuts will not have a link to a menu item. For shortcuts associated with a menu item, click on the Action name for a full description of the command.
  • Many menu and other commands do not have a pre-defined shortcut, but you can assign a shortcut to them in Keyboard Preferences. For convenience, these are listed at the end of the tables below. It is also possible to assign shortcuts to individual Effects, Analyze commands and Generate commands.
  • Similarly, you can change the pre-defined shortcut for any item in Keyboard Preferences.
File Menu Tracks Menu Help Menu Tools Toolbar
Edit Menu Generate Menu Device Toolbar Keyboard focus
View Menu Effect Menu Mixer Toolbar
Transport Menu Analyze Menu Selection Toolbar


Mac OS X users: CTRL = COMMAND; ALT = OPTION. So, for example, CTRL + ALT + K = COMMAND + OPTION + K

File Menu

Action Shortcut Description
New CTRL + N Creates a new and empty project window to start working on new or imported Tracks.
Open... CTRL + O Presents you with a standard dialog box where you can select either audio files, a list of files (.LOF) or an Audacity Project file to open.
Close CTRL + W Closes the current project window, prompting you to save your work if you haven't saved.
Save Project CTRL + S Saves the current Audacity project .AUP file.
Import > Audio... CTRL + SHIFT + I Similar to 'Open', except that the file is added as a new track to your existing project.
Export Audio... CTRL + SHIFT + E Exports to an audio file.
Export Multiple... CTRL + SHIFT + L Exports multiple audio files in one process, one file for each track if there are multiple audio tracks, or labels can be added which then define the length of each exported file.
Exit CTRL + Q Closes all project windows and exits Audacity. If there are any unsaved changes to your project, Audacity will ask if you want to save them.
Menu items assignable in Keyboard Preferences: Save Project As; Save Compressed Copy of Project...; Check Dependencies...; Edit Metadata...; Import > Labels, MIDI, Raw Data; Export Selected Audio; Export Labels; Export MIDI; Apply Chain; Edit Chains; Page Setup; Print.

Edit Menu

Action Shortcut Description
Undo CTRL + Z Undoes the most recent editing action.
Redo CTRL + Y
(Mac/Linux:
CTRL + SHIFT + Z )
Redoes the most recently undone editing action.
Remove Audio or Labels > Cut CTRL + X Removes the selected audio data and/or labels and places these on the clipboard. By default, any audio or labels to right of the selection are shifted to the left.
Remove Audio or Labels > Delete CTRL + K Removes the selected audio data and/or labels without copying these to the clipboard. By default, any audio or labels to right of the selection are shifted to the left.
Remove Audio or Labels > Split Cut CTRL + ALT + X Same as Cut, but none of the audio data or labels to right of the selection are shifted.
Remove Audio or Labels > Split Delete CTRL + ALT + K Same as Delete, but none of the audio data or labels to right of the selection are shifted.
Remove Audio or Labels > Silence Audio CTRL + L Replaces the currently selected audio with absolute silence. Does not affect label tracks.
Remove Audio or Labels > Trim Audio CTRL + T Deletes all audio but the selection. If there are other separate clips in the same track these are not removed or shifted unless trimming the entire length of a clip or clips. Does not affect label tracks.
Clip Boundaries > Split CTRL + I Splits the current clip into two clips at the cursor point, or into three clips at the selection boundaries.
Clip Boundaries > Split New CTRL + ALT + I Does a Split Cut on the current selection in the current track, then creates a new track and pastes the selection into the new track.
Clip Boundaries > Join CTRL + J If you select an area that overlaps one or more clips, they are all joined into one large clip. Regions in-between clips become silence.
Clip Boundaries > Detach at Silences CTRL + ALT + J In a selection area that includes absolute silences, creates individual non-silent clips between the regions of silence. The silence becomes blank space between the clips.
Copy CTRL + C Copies the selected audio data to the clipboard without removing it from the project.
Paste CTRL + V Inserts whatever is on the clipboard at the position of the selection cursor in the project, replacing whatever audio data is currently selected, if any.
Paste Text to New Label CTRL + ALT + V Pastes the text on the clipboard at the cursor position in the currently selected label track. If there is no selection in the label track a point label is created. If a range is selected in the label track a range label is created. If no label track is selected one is created, and a new label is created.
Duplicate CTRL + D Creates a new track containing only the current selection as a new clip.
Labeled Audio > Cut ALT + X Same as the Cut command, but operates on labeled audio regions.
Labeled Audio > Delete ALT + K Same as the Delete command, but operates on labeled audio regions.
Labeled Audio > Split Cut SHIFT + ALT + X Same as the Split Cut command, but operates on labeled audio regions.
Labeled Audio > Split Delete SHIFT + ALT + K Same as the Split Delete command, but operates on labeled audio regions.
Labeled Audio > Silence Audio ALT + L Same as the Silence Audio command, but operates on labeled audio regions.
Labeled Audio > Copy SHIFT + ALT + C Same as the Copy command, but operates on labeled audio regions.
Labeled Audio > Split ALT + I Same as the Split command, but operates on labeled audio regions or points.
Labeled Audio > Join ALT + J Same as the Join command, but operates on labeled audio regions or points. You may need to select the audio and use Edit > Clip Boundaries > Join to join all regions or points.
Labeled Audio > Detach at Silences SHIFT + ALT + J Same as the Detach at Silences command, but operates on labeled audio regions.
Select > All CTRL + A Selects all of the audio in all of the tracks.
Select > None CTRL + SHIFT + A Deselects all of the audio in all of the tracks.
Select > Left at Playback Position [ When Audacity is playing, recording or paused, sets the left boundary of a potential selection by moving the cursor to the current position of the green playback cursor (or red recording cursor).

Otherwise, opens the "Set Left Selection Boundary" dialog for adjusting the time position of the left-hand selection boundary. If there is no selection, moving the time digits backwards creates a selection ending at the former cursor position, and moving the time digits forwards provides a way to move the cursor forwards to an exact point.

Select > Right at Playback Position ] When Audacity is playing, recording or paused, sets the right boundary of the selection, thus drawing the selection from the cursor position to the current position of the green playback cursor (or red recording cursor).

Otherwise, opens the "Set Right Selection Boundary" dialog for adjusting the time position of the right-hand selection boundary. If there is no selection, moving the time digits forwards creates a selection starting at the former cursor position, and moving the time digits backwards provides a way to move the cursor backwards to an exact point.

Select > Track Start to Cursor SHIFT + J Selects a region in the selected track(s) from the start of the track to the cursor position.
Select > Cursor to Track End SHIFT + K Selects a region in the selected track(s) from the cursor position to the end of the track.
Select > In All Tracks CTRL + SHIFT + K Extends the current selection up and/or down into all tracks in the project.
Select > In All Sync-Locked Tracks CTRL + SHIFT + Y Extends the current selection up and/or down into all sync-locked tracks in the currently selected track group.
Find Zero Crossings Z Moves the edges of a selection region (or the cursor position) slightly so they are at a rising zero crossing point.
Move Cursor to Selection Start LEFT When there is a selection, moves the cursor to the start of the selection and removes the selection.
Move Cursor to Selection End RIGHT When there is a selection, moves the cursor to the end of the selection and removes the selection.
Move Cursor to Track Start J Moves the cursor to the start of the selected track.
Move Cursor to Track End K Moves the cursor to the end of the selected track.
Preferences CTRL + P  
(Mac: COMMAND + , )
Opens the Preferences dialog.
Selection to Start SHIFT + HOME Selects all audio from beginning of the track to the cursor.
Selection to End SHIFT + END Selects all audio from the cursor to the end of the track.
Delete Key BACKSPACE Deletes the selection. When focus is in Selection Toolbar, BACKSPACE is not a shortcut but navigates back to the previous digit and sets it to zero.
Delete Key 2 DELETE Deletes the selection.
Selection Extend Left SHIFT + LEFT Increases the size of the selection by extending it to the left. The amount of increase is dependent on the zoom level. If there is no selection one is created starting at the cursor position.
Selection Extend Right SHIFT + RIGHT Increases the size of the selection by extending it to the right. The amount of increase is dependent on the zoom level. If there is no selection one is created starting at the cursor position.
Selection Contract Left CTRL + SHIFT + LEFT Decreases the size of the selection by contracting it from the right. The amount of decrease is dependent on the zoom level. If there is no selection no action is taken.
Selection Contract Right CTRL + SHIFT + RIGHT Decreases the size of the selection by contracting it from the left. The amount of decrease is dependent on the zoom level. If there is no selection no action is taken.
Cursor Left LEFT When there is no selection, moves the cursor one screen pixel to left. When a Snap To option is chosen, moves the cursor to the preceding unit of time as determined by the current selection format. If the key is held down, the cursor speed depends on the length of the tracks.
Cursor Right RIGHT When there is no selection, moves the cursor one screen pixel to right. When a Snap To option is chosen, moves the cursor to the following unit of time as determined by the current selection format. If the key is held down, the cursor speed depends on the length of the tracks.
Cursor Short Jump Left(1) , Moves the cursor one second left when playback is stopped. .
Cursor Short Jump Right(1) . Moves the cursor one second right.when playback is stopped.
Cursor Long Jump Left(1) SHIFT + , Moves the cursor 15 seconds left when playback is stopped. .
Cursor Long Jump Right(1) SHIFT + . Moves the cursor 15 seconds right when playback is stopped.
Set (or Extend) Left Selection (User-assigned) Same as Selection Extend Left.
Set (or Extend) Right Selection (User-assigned) Same as Selection Extend Right.
Menu items assignable in Keyboard Preferences: Move Cursor > to Selection Start, to Selection End; Region Save; Region Restore; Play Region > Lock, Unlock.
Holding SHIFT then left-clicking in the waveform creates a selection between the editing cursor and the click point (or extends the existing selection from its nearest edge). This shortcut cannot be configured in Keyboard Preferences.
(1) The long and short jump times are set by the long and short Seek Time When Playing values in Playback Preferences.

View Menu

Action Shortcut Description
Zoom In CTRL + 1 Zooms in on the horizontal axis of the audio displaying more detail over a shorter length of time.
Zoom Normal CTRL + 2 Zooms to the default view which displays about one inch per second.
Zoom Out CTRL + 3 Zooms out displaying less detail over a greater length of time.
Zoom to Selection CTRL + E Zooms in or out so that the selected audio fills the width of the window.
Fit In Window CTRL + F Zooms out until the entire project just fits in the window.
Fit Vertically CTRL + SHIFT + F Adjusts the height of all the tracks until they fit in the project window.
Go to Selection Start CTRL + [ Moves the left edge of the current selection to the center of the screen, without changing the zoom level.
Go to Selection End CTRL + ] Moves the right edge of the current selection to the center of the screen, without changing the zoom level.
Collapse All Tracks CTRL + SHIFT + C Collapses all tracks to take up the minimum amount of space.
Expand All Tracks CTRL + SHIFT + X Expands all tracks to their original size before the last collapse.
Full screen on/off F11
(Mac: COMMAND + / )
Toggles between normal and full-screen mode.
Menu items assignable in Keyboard Preferences: Show Clipping; History...; Karaoke...; Mixer Board...; Toolbars > Device, Edit, Meter, Mixer, Selection, Tools, Transcription, Transport, Reset Toolbars.
PAGE UP scrolls the project rightwards and PAGE DOWN scrolls the project leftwards, equivalent to a single click in the white area either side of the horizontal scrollbar. These shortcuts cannot be configured in Keyboard Preferences.

Transport Menu

ToDo-2 When Bug 133 is fixed, remove "You need to then use the Play-at-speed shortcut above to restart playback at the new speed." from the "Increase/decrease playback speed" shortcuts.
Action Shortcut Description
Play/Stop SPACE Starts and stops playback (stopping does not change the restart position). Therefore using any play or record command after stopping with "Play/Stop" will start playback or recording from the same Timeline position it last started from. You can also assign separate shortcuts for Play and Stop.
Play/Stop and Set Cursor SHIFT + A Starts playback like "Play/Stop", but stopping playback sets the restart position to the stop point. When stopped, this command is the same as "Play/Stop". When playing, this command stops playback and moves the cursor (or the start of the selection) to the position where playback stopped.
Loop Play SHIFT + SPACE Plays the selection over and over again.
Pause P Temporarily pauses playing or recording without losing your place.
Skip to Start HOME Moves the cursor to the beginning of the project.
Skip to End END Moves the cursor to the end of the project.
Record R Recording begins on a new track at either the current cursor location or at the beginning of the current selection.
Timer Record... SHIFT + T Brings up the Timer Record dialog.
Append Record SHIFT + R Starts recording at the end of the currently selected track(s).
Play One Second 1 Plays for one second centered on the current pointer position (not from the current cursor position). See this page for an example.
Play To Selection B Plays to or from the current pointer position to or from the start or end of the selection, depending on the pointer position. See this page for more details.
Play Cut Preview C Plays for 1 second before the current selection and one second after the current selection, as if the current selection had been cut or deleted. This is useful for previewing what the audio will sound like after the cut. The length of time that is played before and after the selection can be set in the Cut Preview section of Playback Preferences.
Short Seek Left during Playback(1) LEFT  or
,
Skips the playback cursor back one second.
Short Seek Right during Playback(1) RIGHT  or
.
Skips the playback cursor forward one second.
Long Seek Left during Playback(1) SHIFT + LEFT  or
SHIFT + ,
Skips the playback cursor back 15 seconds.
Long Seek Right during Playback(1) SHIFT + RIGHT  or
SHIFT + .
Skips the playback cursor forward 15 seconds.
Play (User-assigned) Single command to start playback immediately.
Stop (User-assigned) Single command to stop playing or recording immediately so that the next playback or recording will start from the same Timeline position it last started from.
Play-at-speed (User-assigned) Equivalent to clicking the Play-at-speed button on Transcription Toolbar.
Adjust playback speed (User-assigned) Displays the Playback Speed dialog. You can type a new value for the playback speed (between 0.01 and 3), or press Tab then use the left and right arrow keys to adjust the slider.
Increase playback speed (User-assigned) Each key press will increase the playback speed by 0.03. You need to then use the Play-at-speed shortcut above to restart playback at the new speed.
Decrease playback speed (User-assigned) Each key press will decrease the playback speed by 0.03. You need to then use the Play-at-speed shortcut above to restart playback at the new speed.
Menu items assignable in Keyboard Preferences: Overdub (on/off); Software Playthrough (on/off); Sound Activated Recording (on/off); Sound Activation Level...; Rescan Audio Devices.
Holding CTRL (or COMMAND on a Mac) while playing, then left-clicking in the waveform moves the playback position to the click point. This shortcut cannot be configured in Keyboard Preferences.
(1) The long and short seek times can be set in the Seek Time When Playing section of Playback Preferences.

Tracks Menu

Action Shortcut Description
Add New > Audio Track CTRL + SHIFT + N Creates a new empty audio track.
Mix and Render to New Track CTRL + SHIFT + M Same as Tracks > Mix and Render, except that the original tracks are preserved rather than being replaced by the resulting "Mix" track.
Mute All Tracks CTRL + U Mutes all the audio tracks in the project as if you had used the mute buttons from the Track Control Panel on each track.
Unmute All Tracks CTRL + SHIFT + U Unmutes all the audio tracks in the project as if you had released the mute buttons from the Track Control Panel on each track.
Add Label at Selection CTRL + B Creates a new, empty label at the cursor or at the selection region.
Add Label at Playback Position CTRL + M
(Mac: COMMAND + . )
Creates a new, empty label at the current playback or recording position.
Move Focus to Previous Track(1) UP Changes the track that responds to keyboard input to the previous (upper) track. If the top track currently has focus no action is taken.
Move Focus to Previous and Select(1) SHIFT + UP As above, but if there is a selection in the current track that selection is extended into the track above.
Move Focus to Next Track(1) DOWN Changes the track that responds to keyboard input to the next (lower) track. If the bottom track currently has focus no action is taken.
Move Focus to Next and Select(1) SHIFT + DOWN As above, but if there is a selection in the current track that selection is extended into the track below.
Toggle Focused Track(1) RETURN  or
ENTER
Changes the focused track from selected to not selected, or from selected to not selected.
Change pan on focused track SHIFT + P Brings up the Pan dialog for the focused track where you can enter a pan value, or use the slider for finer control of panning than is available when using the track pan slider.
Pan left on focused track ALT + SHIFT + LEFT Controls the pan slider on the focused track. Each keypress changes the pan value by 10% left.
Pan right on focused track ALT + SHIFT + RIGHT Controls the pan slider on the focused track. Each keypress changes the pan value by 10% right.
Change gain on focused track SHIFT + G Brings up the Gain dialog for the focused track where you can enter a gain value, or use the slider for finer control of gain than is available when using the track pan slider.
Increase gain on focused track ALT + SHIFT + UP Controls the gain slider on the focused track. Each keypress increases the gain value by 1 dB.
Decrease gain on focused track ALT + SHIFT + DOWN Controls the gain slider on the focused track. Each keypress decreases the gain value by 1 dB.
Mute/Unmute focused track SHIFT + U Toggles the Mute button on the focused track.
Open menu on focused track SHIFT + M Opens the Track Drop-Down Menu on the focused audio track or other track type. In the audio track drop-down, use Up and Down arrow keys to navigate the menu and Enter to select a menu item. Use Right arrow to open the "Set Sample Format" and "Set Rate" choices or Left arrow to leave those choices.
Solo/Unsolo focused track SHIFT + S Toggles the Solo button on the focused track.
Remove focused track SHIFT + C Removes the focused track.
Menu items assignable in Keyboard Preferences: Add New > Stereo Track, Label Track, Time Track; Stereo Track to Mono; Mix and Render; Resample...; Remove Tracks; Align Tracks > Align End to End, Align Together, Start to Zero, Start to Cursor/Selection Start, Start to Selection End, End to Cursor/Selection Start, End to Selection End; Move Selection when Aligning > Start to Zero, Start to Cursor/Selection Start, Start to Selection End, End to Cursor/Selection Start, End to Selection End; Sync-Lock Tracks; Edit Labels...; Sort Tracks > by Start time, by Name.
Holding SHIFT while clicking above or below a selected track adds the SHIFT-clicked track to the selection. This shortcut cannot be configured in Keyboard Preferences.
(1) See Audacity Selection for examples of changing track focus and selection.
Gale: 09Nov13: Updated list of assignable menu items now that there are no items in the keyboard preferences with the same name. Also used arrows consistently for cascade, which takes less space. I think the current system works moderately well until the list of assignable items becomes too long. I really wouldn't want to shunt to a separate page to view potentially assignable items.

Although it would make the page longer, I'm wondering if the assignable menu items listed under each table should be inline but each menu section broken up to reflect the menu separators. I don't mind the length because it is a reference list. I suspect the distinction drawn between "user-assigned non-menu items" and "user assigned menu items" is confusing and underplays the importance of the latter. But I think this is Bill's work mainly so you should get his view.

Generate Menu

Action Shortcut Description
All Generate menu items can be assigned an unused keyboard shortcut in Keyboard Preferences.

Effect Menu

Action Shortcut Description
Repeat Last Effect CTRL + R Repeats the last used effect at its last used settings and without displaying any dialog.
All classes of effects in the Effect Menu can be assigned an unused keyboard shortcut in Keyboard Preferences.


Analyze Menu

Action Shortcut Description
Contrast... CTRL + SHIFT + T Displays the Contrast dialog.
All other Analyze menu items can be assigned an unused keyboard shortcut in Keyboard Preferences.

Help Menu

Action Shortcut Description
Menu items assignable in Keyboard Preferences: About Audacity; Quick Help (in web browser); Manual (in web browser); Screenshot Tools...; Run Benchmark...; Audio Device Info...; Show Log... .

Device Toolbar

Action Shortcut Description
Change audio host SHIFT + H Displays the Select Audio Host dialog for choosing the particular interface with which Audacity communicates with your chosen playback and recording devices.
Change output device SHIFT + O Displays the Select Output Device dialog for choosing the playback device, but only if the "Output Device" drop-down menu in Device Toolbar has entries for devices. Otherwise, an output error message will be displayed.
Change input device SHIFT + I Displays the Select Input Device dialog for choosing the recording device, but only if the "Input Device" drop-down menu in Device Toolbar has entries for devices. Otherwise, an input error message will be displayed.
Change input channels SHIFT + N Displays the Select Input Channels dialog for choosing the number of channels to be recorded by the chosen recording device.

Mixer Toolbar

Action Shortcut Description
Adjust Output Gain (User-assigned) Displays the Output Volume dialog. You can type a new value for the output volume (between 0 and 1), or press Tab then use the left and right arrow keys to adjust the slider.
Increase Output Gain (User-assigned) Each key press will increase the output gain by 0.1.
Decrease Output Gain (User-assigned) Each key press will decrease the output gain by 0.1.
Adjust Input Gain (User-assigned) Displays the Input Volume dialog. You can type a new value for the input volume (between 0 and 1), or press Tab then use the left and right arrow keys to adjust the slider.
Increase Input Gain (User-assigned) Each key press will increase the input gain by 0.1.
Decrease Input Gain (User-assigned) Each key press will decrease the input gain by 0.1.

Selection Toolbar

Action Shortcut Description
Snap To Off (User-assigned) Equivalent to setting the Snap To control in Selection Toolbar to "Off".
Snap To Nearest (User-assigned) Equivalent to setting the Snap To control in Selection Toolbar to "Nearest".
Snap To Prior (User-assigned) Equivalent to setting the Snap To control in Selection Toolbar to "Prior".

Tools Toolbar

Action Shortcut Description
Selection Tool F1 Chooses Selection tool.
Envelope Tool F2 Chooses Envelope tool.
Draw Tool F3 Chooses Draw tool.
Zoom Tool F4 Chooses Zoom tool.
Time Shift Tool F5 Chooses Time Shift tool.
Multi-Tool F6 Chooses Multi-tool.
Next Tool D Cycles forwards through the tools, starting from the currently selected tool: starting from Selection, it would navigate to Envelope to Draw to Zoom to Time Shift to Multi-tool to Selection.
Previous Tool A Cycles backwards through the tools, starting from the currently selected tool: starting from Selection, it would navigate to Multi-tool to Time Shift to Zoom to Draw to Envelope to Selection.

Keyboard focus

Action Shortcut Description
Move backward through Dock, Track View, and Selection Bar CTRL + SHIFT + F6 Each use moves the keyboard focus as indicated.
Move forward through Dock, Track View, and Selection Bar CTRL + F6 Each use moves the keyboard focus as indicated.
Personal tools