Mixing Audio Tracks

From Audacity Development Manual

Jump to: navigation, search
Gale 07Dec11: ToDo-2 There is no mention here or in Tracks Menu of how render handles white space before the audio begins or audio before zero. Should there be? Current behaviour following r11248 is to preserve the clip length by no longer rendering white space between time zero and first audio as silence, and to preserve audio before time zero instead of discarding it. So people who want to export tracks with silent lead-ins preserved now have to generate silence after rendering. I think that tip at least should be in this page.

Mezclando pistas de audio


Mixing refers to the process of combining multiple Audacity tracks which play simultaneously into a single track.

Audacity mixes automatically when playing or exporting, but it can also physically mix selected multiple tracks together into one within the project.

The channel of a track being mixed affects whether it will be mixed into the left channel of the resulting track(s), the right channel, or both (mono). For example, if you have four tracks:

  • Track 1: left channel
  • Track 2: left channel
  • Track 3: right channel
  • Track 4: mono channel
and you select them all and perform a Mix and Render, you will end up with one stereo track: the left channel will contain a mix of tracks 1, 2, and 4 and the right channel will contain a mix of tracks 3 and 4.

Mixing can be done for a number of reasons, for example mixing speech with background music to make a podcast, or adding different instruments into the same song. Concatenating songs (for example, playing three songs one after the other) does not necessarily involve mixing, but if you wanted the songs to fade into each other it would involve mixing.

Within an Audacity project, you can physically mix selected multiple selected tracks into a single mono or stereo track using either of two explicit mix commands:

However in Audacity, mixing is automatic. You could just put audio into two different tracks, play to listen to the result then export it as an audio file like MP3 or WAV or burn the WAV to Audio CD.

However once audio has been finally mixed (as in an audio file you might import into Audacity) it is essentially impossible to separate out all the original parts again; it's like trying to take the banana out of a banana milkshake after you've already put it through the blender. There are a few occasions when it actually is possible to separate sounds a bit - you can sometimes isolate the bass, or remove the lead vocals. But these processes don't always work well and usually cause some quality loss. So remember, as long as the multiple tracks are inside an Audacity project, you can manipulate them independently, but once you export as a mixed down file you can't expect to separate the different parts again. So keep your Audacity project around if you plan to continue editing!

Although Audacity by default exports files as either two channel stereo or single channel mono (if exporting unpanned mono tracks), you can also export multi-channel files having more than two channels, such as a 5:1 file. To enable this, choose "Use custom mix" in the Import / Export Preferences.

The controls used for mixing are the Mute and Solo buttons and the Gain (-.....+) and Pan (L.....R) sliders.

TrackToMix.png

In the above example, mixing the mono (upper) and stereo (lower) track means that the audio of the mono track will be heard equally in both left and right channels of the resulting stereo mix.

Muting and Soloing

When working with multiple tracks, it's often important to be able to hear just one at a time. Each track has a Mute and a Solo button, allowing you to temporarily hear just some of your tracks - see the figure above

  • Mute causes a track to be silenced. More than one track can be muted.
  • Solo can behave in two different ways depending on the setting made in Tracks Preferences.
    • Default behavior is that Solo silences all of the tracks except the ones being soloed. More than one track can be soloed, and soloing overrides muting.
    • Alternative behavior is that only one track can be soloed at a time. Soloing still overrides muting.

A third option in Tracks Preferences is to hide the Solo button from tracks, leaving just a Mute button which silences whichever tracks it is applied to.

You can press the Mute and Solo buttons while tracks are playing.

If you're using the keyboard, SHIFT+U toggles muting on the currently focused track which has the yellow border, and SHIFT + S toggles soloing. The solo shortcut works even if you hide the Solo button.

Sometimes it can be handy to export a preliminary mix with one or more of the tracks left out. Exporting will automatically ignore any tracks on which the Mute button is pressed.

Gain and panning

Above the Mute / Solo buttons, each track has a - / + gain slider which adjusts the track's volume, and an L / R pan slider which adjusts the track's stereo position in the overall mix - whether it comes from the left speaker, right speaker or in-between. To change the value, just click on the slider and drag. For finer control when dragging, hold SHIFT while dragging or double-click on the slider or slider scale to enter a precise value as text.

The normal range of gain is from -36 dB to 36 dB. If you need more, choose Effect > Amplify.

If you're using the keyboard, use:

  • ALT + SHIFT + UP to increase the gain on the focused track or ALT + SHIFT + DOWN to reduce it
  • Use ALT + SHIFT + LEFT to pan left on the focused track or ALT + SHIFT + RIGHT to pan right.

Or press SHIFT + G to adjust the gain in a dialog box or SHIFT + P to adjust the pan.

If you don't see the gain or pan slider for a track, you may need to make it taller. Position the mouse on the bottom edge of the waveform and drag downwards. You can use the button with the upward pointing arrow (below the pan slider) to collapse the track upwards to a minimal height.

Explicit Mixing and Rendering

While mixing is automatic, there are times when you may want to explicitly tell Audacity to mix several tracks. This is useful in several ways:

  • You can consolidate tracks which you have finished working on, making it easier to see the other tracks without scrolling up and down
  • Playback may respond more quickly with fewer tracks
  • You can see what the final mix will look like as a waveform so as to check the overall level of the final mix before exporting it.

To mix explicitly, select all the tracks you want to mix together then choose either Tracks > Mix and Render or Tracks > Mix and Render to New Track (shortcut CTRL + SHIFT + M).

For mouse users, a quick way to select multiple tracks is to select the first track by clicking on its Track Control Panel, then hold SHIFT while clicking on the Track Control Panels of the other tracks you want to select.

Several things happen when you choose either Mix and Render command.

  • All selected tracks are mixed down to a single track called "Mix".
  • If you choose "Mix and Render", the resulting "Mix" track replaces the selected original tracks.
  • If you choose "Mix and Render to New Track", the original tracks are preserved so that the resulting "Mix" track becomes an additional track in the project.
  • The "Mix" track is always placed underneath any non-selected or remaining tracks.
  • The new mixed track will be stereo unless the tracks you mixed were mono tracks panned to center.
  • If any of the original tracks did not match the sample rate of the project (set at bottom left of the project window in Selection Toolbar), they will be resampled to match the project rate.
  • Any envelope points defining amplitude modifications will be applied and the previous envelope points removed.
  • Gain and panning changes will be applied and the sliders reset to normal in the mixed track.
  • Mute and Solo button states will be released.

You can always Edit > Undo if you're not happy with the results of Mix and Render, then make changes and try it again.

Mixing Levels

The act of mixing multiple tracks adds the waveforms together. In most cases this will cause the mixed track to have a higher peak and RMS (average) level than the individual pre-mixed tracks, though this is not always true by definition. How much (or whether) the peak level increases and how much louder it actually sounds depends on how related the waveforms of the mixed tracks are.

When peaks or troughs in the waveform coincide, the waveforms will reinforce each other, leading to an increased signal level. In fact if you combined two identical tracks, the signal level would exactly double, leading to an increase in peak level of 6 dB. But when a peak in one track coincides with a trough in another track the waveforms will tend to cancel each other out, leading to a lower level in the mix at that point.

Also the more tracks that have audio at the same point on the Timeline, the higher the mix level is likely to be.

The overall mix level is indicated on the green playback meter in Meter Toolbar when the project is playing. You can see individual meters for each track (showing the levels as modified by the track's gain/pan sliders and mute/solo buttons) if you enable View > Mixer Board.

Warning icon Because mixing tracks is additive, the combined level may show clipping distortion in Meter Toolbar. In that case, you should use the gain sliders on one or more tracks to reduce the overall level.
  • If you already have the balance of the mix (the levels of the tracks relative to each other) exactly as you want it, select all the tracks using CTRL + A then choose Effect > Amplify. Enter a negative value in the "Amplification (dB)" box which will reduce the level of all the tracks by the specified value.
Personal tools