Installing Effect, Generator and Analyzer plug-ins on Mac OS X/macOS

From Audacity Development Manual

Jump to: navigation, search


You can download and install plug-ins to add extra functionality to Audacity. Plug-ins can give you extra effects, or more audio generation and analysis capabilities.

Contents

  1. Installing Audio Unit plug-ins
  2. Installing Nyquist plug-ins
  3. Installing VST plug-ins
  4. Installing LADSPA plug-ins
  5. Installing LV2 plug-ins
  6. Installing VAMP plug-ins
  7. Uninstalling plug-ins
  8. How can I solve Audacity crashing after I add a plug-in?

Installing Audio Unit plug-ins

Audio Units (AU) are a system-level plug-in architecture provided on Mac OS X and macOS computers.

To add a new Audio Unit effect, place it in either of the following system plug-in directories:

  • ~/Library/Audio/Plug-Ins/Components (user plug-ins)
  • /Library/Audio/Plug-Ins/Components (system-wide plug-ins)

Then use Effect > Add / Remove Plug-ins... to enable the Audio Unit effects and load them into Audacity, For details see Manage Effects.


Installing Nyquist plug-ins

Nyquist plug-ins provide most of the optional effects underneath the divider in the Effect menu. They are also used to provide some of Audacity's built-in audio generators and analysis tools. A wide range of additional Nyquist effect, generation and analysis plug-ins can be obtained from Download Nyquist Plug-ins on our Wiki.

To install new Nyquist plug-ins, place them in Audacity's "Plug-Ins" folder at ~/Library/Application Support/audacity/Plug-Ins.

To load the new effects into Audacity so they are available in the menu, use the Plug-in Manager: Effects, Generators and Analyzers dialog.

Warning icon Some Nyquist plug-ins could crash while processing very long audio selections (typically an hour or more). This is due to the plug-in using a large amount of memory and is a known issue in Audacity's current Nyquist implementation. Try using the plug-in on shorter selections instead.


Installing VST plug-ins

Audacity supports almost all VST effect plug-ins on Mac including "shell" VST's that host multiple VST effects.

To install new VST plug-ins, place them in Audacity's "Plug-Ins" folder at ~/Library/Application Support/audacity/Plug-Ins.

Other possible locations on Mac are:
  • ~/Library/Audio/Plug-Ins/VST
  • /Library/Audio/Plug-Ins/VST
  • All paths specified by the "VST_PATH" environment variable.
All the directories where you can place VST plug-ins are searched recursively, which means that plug-ins that are inside their own folder in that directory should still be found by Audacity.

You can install new VST effects into Audacity by using the Effect > Add / Remove Plug-ins... menu item. This opens the Plug-in Manager: Effects, Generators and Analyzers dialog where you can select and enable the new effects then click OK to load them. Next time you launch Audacity the enabled effect(s) will be cached and you will not need to re-enable them.

Warning icon The list of effects in the dialog will include any detected VST instrument (VSTi) plug-ins (such as synths) and any real-time VST effects that are capable of changing audio data while it's being written to disk. Neither of these are yet supported and they will not load even if you enable or re-enable them in the dialog.

Why do some VST plug-ins not work or display incorrectly?

Audacity will by default display VST effect plug-ins with a full graphical interface where the plug-in supplies this.

VST instruments (VSTi) (such as synths) and real-time VST effects (that change the audio data while it's being written) are not yet supported. These will not load even if you enable or re-enable them in the Plug-in Manager: Effects, Generators and Analyzers dialog. VST 3 plug-ins are not supported.

If any plug-in displays incorrectly, you can use the Manage button Manage button icon W10.png in the effect's dialog then choose Options... to open the VST Effect Options for that effect. Then remove the checkmark from the "Enable graphical interface" checkbox CheckboxNotChecked.png Enable graphical interface and click OK. When you reopen the effect it will display a simpler tabular interface.

Warning icon On Mac, Audacity is a 32-bit application so will not see 64-bit versions of VST plug-ins, even on 64-bit operating systems.

If you experience a problem with a specific VST effect plug-in in Audacity, please contact us.


Installing LADSPA plug-ins

The LADSPA plug-in architecture was originally developed on Linux. Audacity supports LADSPA effects on Mac as well as GNU/Linux. You can download and install a set of over 90 LADSPA plug-ins. You can then choose which LADSPA plug-ins to enable in the Plug-in Manager: Effects, Generators and Analyzers dialog.

To install new LADSPA plug-ins, place them in Audacity's "Plug-Ins" folder at ~/Library/Application Support/audacity/Plug-Ins.

Then use Effect > Add / Remove Plug-ins... to enable the LADSPA effects and load them into Audacity, For details see Plug-in Manager: Effects, Generators and Analyzers.

Audacity will also load LADSPA plug-ins from the following system locations:
  • The path specified by the LADSPA_PATH environment variable
  • ~/Library/Audio/Plug-Ins/LADSPA
  • /Library/Audio/Plug-Ins/LADSPA


Installing LV2 plug-ins

LV2 is a more advanced evolution of the LADSPA plug-in architecture which was originally developed on Linux. Audacity supports both LV2 effects on Mac as well as GNU/Linux. There are not yet many pre-compiled LV2 plug-ins for Mac, though it may be possible to compile some Linux LV2 plug-ins for other operating systems.

To add a new LV2 effect, place its complete ".lv2" folder (not the files alone) at the top level of any of the following searched for locations:

  • ~/.lv2
  • ~/Library/Audio/Plug-Ins/LV2
  • /Library/Audio/Plug-Ins/LV2
  • /usr/local/lib/lv2
  • /usr/lib/lv2
Search paths where Audacity looks for LV2 plug-ins may also be specified by setting the LV2_PATH environment variable. The path listed below is legitimate.
  • $HOME/.lv2:$HOME/Library/Audio/Plug-Ins/LV2:/Library/Audio/Plug-Ins/LV2:/usr/local/lib/lv2:/usr/lib/lv2

Then use Effect > Add / Remove Plug-ins... to enable the LV2 effects and load them into Audacity, For details see Plug-in Manager: Effects, Generators and Analyzers.


Installing VAMP plug-ins

VAMP plug-ins are usually for analyzing audio so will appear under Audacity's Analyze Menu. You can do interesting things like attempt to track beats, note pitches, chords or frequencies. Any VAMP plug-ins whose output is suitable for a label track should work in Audacity on Mac. To add a new VAMP analysis tool, add the plug-in's DLL, DYLIB or SO file and any supplied category or RDF files to any of the VAMP search locations then enable the tool in the Plug-in Manager: Effects, Generators and Analyzers dialog.


Uninstalling plug-ins

Plug-ins can be removed using Effect > Add / Remove Plug-ins... and then removing the file from the relevant file location, so that they do not appear again in Plug-in Manager.

Plug-ins shipped with Audacity can be found inside Audacity.app (in the Applications folder, or wherever you have installed Audacity). The path to the plug-ins is for example /Applications/Audacity.app/Contents/plug-ins. You can reach the Contents directory by right-clicking or CTRL-clicking over Audacity.app and selecting Show Package Contents.

How can I solve Audacity crashing after I add a plug-in?

Please see this FAQ

If you discover a specific plug-in that misbehaves in Audacity, please email our feedback address. Please include any available Debug report that Audacity generates.
Views

Donate securely by PayPal, using your credit card or PayPal account!

Useful External Links