Tutorial - Audacity Settings for Recording

From Audacity Development Manual
Jump to: navigation, search


Now that you know you're getting sound into the computer, it's time to launch Audacity and possibly change some of the basic settings to enable recording.

You may not need to change any of these settings as Audacity's default settings are designed to work well for you right from the start, so much so that you can probably skip-read this page.

Your first recording with a microphone is probably best done without playthrough of additional sounds, and unless you know you have a stereo microphone, using mono.

Nothing goes 'wrong' if you attempt to record in stereo with a single microphone, though you may find that only one of the two stereo tracks has sound.

To just use the sound from the microphone:

Go to Edit > Preferences (or Audacity > Preferences on Mac) then select the Recording section, and make the following settings in the Playthrough section
  • unchecked checkbox Other tracks while recording (overdub)
  • unchecked checkbox Software playthrough of input

To record in the most standard way:

In the Recording section of Preferences make the following settings:
in the Sound Activated Recording section
  • unchecked checkbox Enable
in the Options Section
  • unchecked checkbox Always record on a new track
In the Quality section of Preferences make the following settings:
in the Sampling section
  • Default Sample Rate: 44100 Hz  menu dropdown
  • Default Sample format: 32-bit float  menu dropdown
On a Mac you are probably best off with a USB microphone, as a typical PC microphone will need a small amplifier between it and the computer.

Project Sample Rate

The project sample rate in Hz can be seen, and changed if required, in the Selection Toolbar at the bottom of the Audacity window:

Selection Toolbar zeroed.png

The sample rate defines the number of digital audio samples per second taken from a continuous analog signal.

44100 Hz is standard for creating files that can be burned to Audio CD or for high-quality MP3 files.

This is the default setting in Audacity and is best left at that setting for your recordings.


Project Sample Format

The Project Sample Format (also known as Bit Depth or Word Size) is the number of computer bits present in each audio sample. It determines the dynamic range of the audio.

Audacity's default is set to 32-bit float. This is good for editing and processing audio. It is strongly recommended that you retain the default setting, however if you really need to change your sample format this can only be done in the Quality section of Preferences.

You can easily downsample to 16-bit (the standard for creating WAV files that can be burned to audio CD) when exporting later.

See Digital Audio for more explanation of sample rates and formats.


Temporary Files

Most users have only one hard disk. However, if you have multiple hard disks, you will want to make sure that Audacity uses your largest or fastest hard disk to store audio. Open the Preferences (in the Edit menu, or the Audacity menu on Mac) and click on the Directories tab. Make sure that the directory listed is on your preferred hard disk.

Warning icon If your home directory is mounted from a remote server, you definitely do not want Audacity's temporary directory to be there!


Software Playthrough

Now click on Transport > Transport Options and, if you are recording from a microphone, make sure that Software Playthrough is not checked - Software Playthrough will cause undesirable feedback from the computer speakers to the microphone.

If you are recording a guitar or keyboard and want to hear the instrument through the computer speakers, make sure that Software Playthrough is checked.

Using Software Playthrough will cause a slight delay between time you play a note and the time you hear it. The amount of delay will vary between computers and operating systems. There is no way to avoid this delay. If you find it bothersome, the best solution is to play the guitar or keyboard through a mixer and plug headphones into the mixer.
Bulb icon Hardware playthrough:

This is a method available on some Windows and Linux machines that lets you unmute the input directly in the sound device. To use this, open the operating system sound mixer, then the Playback section, then unmute the input device (microphone or line-in) and turn the volume up. You can find the system mixer in the Control Panel at Sound on Windows. On Linux, it may be possible to unmute input devices in ALSAmixer then set playback and recording devices in Audacity to the (hardware) device.

Warning icon Macs have not had proper hardware playthrough support for some years.

If hardware playthrough is required it is best to use an external USB or Firewire audio device that has a headphones jack for no-latency monitoring (such as the Behringer UCA 202 or Zoom H2).

Overdub off

Now click on Transport > Transport Options again and make sure that "Overdub (on/off)" is not checked. When this option is enabled Audacity will play other existing tracks while recording a new one. You can decide which tracks will play according to their mute/solo buttons on the Track Control Panel.

It is unlikely you will need overdub for your first recording. If you do want to overdub by (for example) singing over a recorded instrumental track, you should be aware of the Latency correction preference.

Latency correction

On most computer systems there will be a delay known as latency between singing or hitting your note and it being laid down in the recording. When Transport > Transport Options > Overdub (on/off) is set to "on" and you record with another track already present, Audacity will push the recorded track backwards by 130 milliseconds to compensate for the delay. If your latency is constant, you can adjust the Latency correction value so that your recorded tracks should end up properly synchronized with the other tracks after correction. To set a custom latency value for your system, see the Latency Test page.


Sound Activated Recording

Also at Transport > Transport Options make sure that "Sound Activated Recording" is not checked. "Off" is the default setting.

When this is enabled, recording will automatically start or resume when the recording volume rises above the chosen threshold level, and pause when the level falls below that threshold. You cannot pause Sound Activated recordings manually using the Pause button or corresponding menu item or shortcut.


Audacity Preferences

If you prefer, you can make the above settings in your Audacity Preferences. To access this, use Edit > Preferences... (or Audacity > Preferences... on Mac).

The image below shows the Recording section of Preferences:

Preferences Recording.png

There are many other settings that can be made in Preferences. Do take some time to explore and understand these.

For example Sample Rate and Sample Format can be changed in the Quality section of Preferences.


Links

>  Forward to: Tutorial - Selecting Your Recording Device

<  Back to: Tutorial - Connecting Up

|< Tutorial - Your First Recording