FAQ:Editing

From Audacity Manual

Jump to: navigation, search


>  Forward To: FAQ:Errors

<  Back to: FAQ:Opening and Saving Files

|< Index of Frequently Asked Questions

Contents


It's Not Working!

Why can’t I use the effects or other menu items?

Many menu items and other functions are disabled while playing, recording, or paused. To enable them, press the yellow Stop button The Stop button. To stop playback and set the cursor where you stopped, so playback resumes from there, you can use the keyboard shortcut SHIFT + A.

All effects, most Edit Menu items and Cut, Copy, Trim and Silence in Edit Toolbar require you to select the audio you want to change.

  • To select a specific region of audio, click and drag with the Selection tool enabled so as to highlight the selected track.
  • To select all the audio in the project, choose Edit > Select > All.
If you choose an effect or other menu item requiring a selection without making a selection, Audacity will by default select all the audio in the project.

If preferred you can disable this behaviour in the Tracks Preferences by unchecking Select all audio in project, if none selected. Menu items requiring a selection will then be grayed out if there is no selection.


back to top

Why can't I select less than one second or click between whole seconds ?

Change "Snap To" in Selection Toolbar to "Off". If Snap To is set to "Nearest" or "Prior", the selection edges or cursor will be force-snapped to an exact time unit (for example, whole seconds) or to the nearest sample or media frame, according to the selection format chosen in Selection Toolbar. "Nearest" or "Prior" determines respectively whether the nearest or previous time unit, sample or frame is snapped to.

Warning icon If Snap To is set to "Nearest" or "Prior", selection format set to seconds and you are zoomed in with less than one second of track visible, you won't be able to click or select in the track until you zoom out or set Snap To to "Off".

back to top


Why do I hear clicks when I remove or paste audio, or at the start or end of the track?

Clicks where audio is removed or pasted may be caused by DC offset in the waveform or by poor selection of the edit points.

DC offset may also cause a click at the start or end of the track, even if you don't edit the audio before exporting. Make it part of your workflow to use the Normalize effect with "Remove any DC offset" checked as soon as audio is recorded or imported. You can set the Import / Export Preferences to run Normalize automatically on all the project tracks when importing any audio file.

When removing or pasting audio, Edit > Find Zero Crossings can be used to move the cursor point or selection boundaries to a safe position where the audio samples are at silence. This works very effectively on mono tracks.

In stereo tracks, zero crossing points may be in a different place on the left and right channels, so Find Zero Crossings may still leave a click in one of the channels. Splitting a stereo track to left and right channels then finding zero crossings on each channel will not help, because the cut or paste must be in the same place on each channel to keep synchronization.

The solution is to take care where edit points are positioned in stereo tracks. For example, zoom in then try to place the selection edges or cursor point where there is silence, or at the onset of a strong beat (which will mask any click).

If none of these solutions are available, you can fix a click by whichever of the following methods produces the best-sounding result:


back to top

I'd Like To...

How do I select audio in one track?

See Audacity Selection for an extended overview of the principles of selecting audio.

  • How do I select audio in one track using the mouse?
    • Make sure Selection Tool Selection Tool from Tools Toolbar is selected, or press F1 on your keyboard. Left-click to place the cursor on the track's waveform, keep holding the left mouse button, drag the mouse in either direction then release the button. Zoom in if you need to see from left to right in more detail.
  • How do I expand or contract an existing selection using the mouse?
    • Hover over either selection edge. When the mouse pointer changes to a pointing finger, hold down the left mouse button and drag in either direction. Release the button when the edge is in the correct position.
    • It is often quicker instead to hold SHIFT then left-click and hold the button at the point to which you want to move the selection edge. Then drag to fine tune the edge position and release when satisfied. When contracting a selection, hold SHIFT and click inside that selection to left of center to move the left edge, or click to right of center to move the right edge.
  • How can I select and modify selections using the keyboard instead?
  1. If necessary, use UP or DOWN arrow on the keyboard to give focus to the track, then ENTER to select it.
  2. Press J to move to the start of the track, then use SHIFT + . to seek (move the cursor) 15 seconds to right or . to seek one second to right. Or press K to move to the end of the track and use comma instead of period in the shortcut to seek left. The seek lengths can be changed in Playback Preferences. When not playing the track, LEFT or RIGHT nudge the cursor in that direction by one screen pixel.
  3. When the cursor is in the correct position, use SHIFT + RIGHT to expand the selection rightwards or SHIFT + LEFT to expand leftwards. CTRL + SHIFT + LEFT contracts the selection from the right and CTRL + SHIFT + RIGHT contracts from the left.

Alternatively, use Selection Toolbar to place the selection accurately without the need to zoom in.

  • Is there a quick way to select from the cursor to start or end?
    • Select from cursor to track start: Choose Edit > Select > Track Start to Cursor or use the SHIFT + J shortcut.
    • Select from cursor to track end: Choose Edit > Select > Cursor to Track End or use the SHIFT + K shortcut.
    • Select from cursor to project start: Hold the SHIFT key and click on the The Skip to Start button Skip to Start button. Alternatively, use the SHIFT + HOME shortcut. This may be useful if one more of your tracks do not start at time zero.
    • Select from cursor to project end: Hold the SHIFT key and click on the The Skip to End button Skip to End button. Alternatively, use the SHIFT + END shortcut. This may be useful if your tracks are of unequal length.

See also:

back to top


How do I extend or move the selected region into other tracks?

A selection is always shown on the Timeline, but the selection only exists in a track when that track is selected. For example, you may want to extend the selected region up or down into more than one track, which lets you edit the selection in all those tracks at the same time. To make that selection display in other tracks, you have to change which tracks are selected.

  • To extend the selected region up or down into other tracks: Hover over either selection edge. When the mouse pointer changes to a pointing finger, hold down the left mouse button then drag directly up or down into an adjacent track.

    If you also want to extend or contract the selection to left or right, you can drag left or right before releasing the button.

    If you don't want to change the selection length, there is no need to drag. Hold SHIFT while clicking on the Track Control Panel to left of the waveform to include that track in the selection, thereby extending the selection into it.

    • Keyboard users can include tracks in the selection by using UP or DOWN to change the track that has the yellow focus border, followed by ENTER to select that track. Hold SHIFT while pressing UP or DOWN to extend the selection up or down adjacent tracks.
  • To move the selected region into other tracks: Extend the selection as above into all the tracks which you want to contain the selection. Then hold SHIFT and click on the Track Control Panel of the track or tracks from which you were moving the selection, so as to deselect those tracks.
    • Keyboard users can press UP or DOWN to move the focus to the track from which the selection is to be removed, then press ENTER.
Extending or moving the selected region into other tracks only determines if the selected region appears in a track. It does not move the audio content of the selection. To copy or move the content of a selection, use Edit > Copy or Edit > Cut then Edit > Paste.

See also:

back to top

How do I combine two files into one longer file?

Follow these steps to splice two files together:

  1. Import both files into Audacity
  2. Select the second file by clicking above the Mute/Solo buttons on its Track Control Panel (where the sample rate in Hz is shown)
  3. Choose Edit > Find Zero Crossings
  4. Choose Edit > Remove Audio > Cut
  5. Place the cursor at the end of the first track by clicking in it then pressing K
  6. Choose Edit > Paste
  7. Optionally, click the X track close button top left of the Track Control Panel on the tracks you cut the audio from.
A time-saving alternative if you have many tracks to combine is to choose Edit > Select > All, then Tracks > Align Tracks > Align End to End. This aligns the selected tracks one after the other so they follow the Timeline. If it's more convenient to make the result into one Audacity track, you can then choose Tracks > Mix and Render.

Press the green "Play" button to hear the result, and use the File > Export Audio... command to save it as an audio file.

back to top

How do I mix two tracks together?

To mix two files, import both of them into Audacity. They will appear in separate tracks.

When you press the Play button, you'll hear both tracks play together. Because this adds the sounds together, the end result may become too loud and distorted. To fix this, turn down the -...+ gain sliders on each track until you see no clipping light on the Meter Toolbar. Use the L...R pan sliders to adjust the spatial position of each track in the mix. You can also use View > Mixer Board... to display the controls for each track together in a separate window.

When you use File > Export Audio..., the tracks will be automatically mixed to an audio file for use in other applications. If you want to mix tracks together explicitly before export, so that they are replaced with a single mixed track, select the tracks, then Tracks > Mix and Render.

For more details, see Mixing Audio Tracks.

back to top

Can I remove the vocals from a recording to make a Karaoke track?

This is only possible for certain stereo tracks. When the vocals are exactly the same on both stereo channels, you can remove them by “subtracting” one channel from the other. This works for recordings where the vocal track is mixed exactly in the center and stereo reverberation has not been added. See this tutorial: Vocal Removal and Isolation.

back to top


Can I create Ringtones with Audacity?

See this tutorial in the Manual: Making Ringtones.

back to top


Why do I see a lot of vertical red lines in the track I just recorded?

This happens when you have an oversaturated recording, where clipping has occurred, that is, the signal has exceeded the maximum allowed level. The vertical red lines show where clipping has happened. The clipping indicators can be turned on and off (Audacity's default setting is "off") by selecting View > Show Clipping.

See the Audacity Waveform page for more explanation of how the waveform is displayed.

back to top


Can Audacity preview or apply effects live, in real time?

Audacity cannot yet apply effects in real time while you are previewing or recording. This is one of the most commonly asked for Feature Requests, but it requires substantial changes to Audacity to implement it. If you would like us to add your vote please either e-mail our feedback address or post on the Adding Features to Audacity section on the Audacity Forum.

Advanced users can apply effects to recordings in real time by applying the effects in a VST host and routing the effect output to be recorded by Audacity. See this Forum topic and ask on the Forum if you need any help.


back to top


How do I convert a stereo track to mono, or mono to stereo?

Use Tracks > Stereo Track to Mono. This converts the selected stereo track(s) into the same number of mono tracks, combining left and right channels equally. This command is not available for stereo tracks split into left and right channels or where the start or end positions of the channels are different. Stereo Track to Mono mixes the two channels together then reduces the volume of the mix by -6 dB (halves the volume) to produce an average of the two channels. Therefore if one channel of the stereo track is louder than the other, the peak volume of the resulting mono track will be reduced. The resulting track will never clip if the original stereo track does not.

Alternatively you can use Split Stereo to Mono from the Track Drop-Down Menu in the Track Control Panel to create separate mono tracks for each channel. If you want to discard one faulty or noisy channel entirely, use the X button top left of the track, or select the track then choose Tracks > Remove Tracks. Split Stereo to Mono can also be useful if you are making a mix of multiple tracks. You have more control using the Pan Sliders on mono tracks than if you use the Track Drop-Down Menu to Split Stereo Track to left and right channels.

There is no general audio benefit in converting a mono track to stereo. A mono track will already play on both speakers of a stereo player. If you want to add an illusion of stereo space and depth, try this Pseudo-Stereo plug-in.


back to top


>  Forward To: FAQ:Errors

<  Back to: FAQ:Opening and Saving Files

|< Index of Frequently Asked Questions

Views
Useful External Links