Installing Effect, Generator and Analyzer plug-ins on Linux

From Audacity Development Manual
Jump to: navigation, search
You can download and install plug-ins to add extra functionality to Audacity. Plug-ins can give you extra effects, or more audio generation and analysis capabilities.

Audacity on GNU/Linux supports a large number of Nyquist, LADSPA, LV2 and Vamp effects. VST effects are now supported in Audacity on Linux and can be installed as described at VST Effects. However native Linux VST effects are quite rare. Consequently, if a specific VST effect is required on Linux, it may be necessary to employ workarounds such as running Audacity for Windows in a virtual machine.

Audacity supports 64-bit effects in VST, LADSPA and Vamp format on 64-bit Linux systems (conversely, 32-bit plug-ins in those formats will not load into Audacity on 64-bit Linux).
Tip It is strongly recommended, when installing third-party plug-ins, that you thoroughly test the plug-in on non-critical project data before using it in production use on a live project.

There is information about some plug-ins that are known to fail or crash Audacity on this Wiki page.

Contents

  1. Installing Nyquist plug-ins
  2. Installing LV2 plug-ins
  3. Installing LADSPA plug-ins
  4. Installing Vamp plug-ins
  5. Installing VST plug-ins
  6. How can I solve Audacity crashing after I add a plug-in?


Installing Nyquist plug-ins

Nyquist plug-ins provide most of the optional effects underneath the divider in the Effect menu. They are also used to provide some of Audacity's built-in audio generators and analysis tools. A wide range of additional Nyquist effect, generator and analysis plug-ins can be obtained from Download Nyquist Plug-ins on our Wiki.

If the plug-in is downloaded as a ZIP archive, the contents of the package must be extracted. This can usually be achieved with the command:
unzip file.zip -d destination_folder
Alternatively, most Linux distributions include a GUI application for extracting ZIP archives.

Nyquist plug-ins provide most of the optional effects underneath the divider in the Effect menu. They are also used to provide some of Audacity's built-in audio generators and analysis tools. A wide range of additional Nyquist effect, generation and analysis plug-ins can be obtained from Download Nyquist Plug-ins on our Wiki.

The easiest and recommended way to install a new Nyquist plug-in is to use the Tool Nyquist Plug-in Installer which is itself a Nyquist plug-in that simplifies the installation of other Nyquist plug-ins.

All Nyquist plug-ins are plain text files that have the filename extension '.NY'. This plug-in installer provides a file browser for selecting the plug-in '.NY' file, and then copies the file to the correct location. Once the plug-in has been installed, it may be enabled in the Plug-in Manager.

Accessed by: Tools > Nyquist Plug-in Installer...
Nyquist Plug-in Installer.png


Advice The information below about manual installation of Nyquist plug-ins is provided for the benefit of system administrators that may have specific requirements. End users should use the method described above.

Per user installation

It is also possible to add a new Nyquist plug-in manually by adding it to the correct location that Audacity expects, it can be performed with standard user permissions.

  1. If it does not already exist, create a folder called .audacity-files in your home directory. Note that the dot as the first character indicates that this will be a hidden folder, so if using a graphical file browser, enable viewing hidden files (for most graphical file browsers, this is an option in the "View" menu).
  2. Add a sub-directory to .audacity-files and name it plug-ins. The location of this folder may be described as ~/.audacity-file/plug-ins, where "~/" means your home folder.
  3. Copy or move the Nyquist plug-in file (with ny or NY file name extension) into the ~/.audacity-files/plug-ins folder.
    • If the plug-in includes a help file or help folder, that file should usually be copied or moved to the same location as the NY file. Check the plug-in documentation for details.
  4. To enable the new effects so they are available in the Audacity menu, use the Plug-in Manager: Effects, Generators and Analyzers dialog.

System-wide installation

This will install the plug-in for all users and requires root permissions.

  1. Copy or move the Nyquist plug-in file (with ny or NY file name extension) into:
    • /usr/share/audacity/plug-ins if Audacity was installed from a repository package
    • /usr/local/share/audacity/plug-ins if you compiled Audacity from source code.
    • If the plug-in includes a help file or help folder, that file should usually be copied or moved to the same location as the NY file. Check the plug-in documentation for details.
  2. To enable the new effects so they are available in the Audacity menu for the current user, use the Plug-in Manager: Effects, Generators and Analyzers dialog.

Note that the effect is loaded per user, but will be available for loading to all users.

Audacity can currently load Nyquist plug-ins from other locations, but it is recommended to use the locations listed above. In particular, ~/.audacity-data/Plug-Ins is now deprecated as a location for Nyquist plug-ins, even though it is still supported.

Advice Some Nyquist plug-ins could crash while processing very long audio selections (typically an hour or more). This is due to the plug-in using a large amount of memory and is a known issue in Audacity's current Nyquist implementation. Try using the plug-in on shorter selections instead.


Installing LV2 plug-ins

LV2 is a more advanced evolution of the LADSPA plug-in architecture. LV2 effects are platform-native for Linux and support real-time preview in Audacity.

Advice It is generally recommended to use your system's package manager to install LV2 plug-ins that have been built and tested for your Linux distribution. After installing, the effects need to be enabled in the Plug-in Manager.
The instructions below provide hints to help experienced Linux users that may need to install plug-ins that are not available from their distribution's repositories.

To add a new LV2 effect, place its complete ".lv2" folder (not the files alone) at the top level of any of the following searched for locations:

  • ~/.lv2 (per user installation)
  • /usr/local/lib/lv2 or /usr/local/lib64/lv2 (custom system-wide installation)
  • /usr/lib/lv2 or /usr/lib64/lv2 (package manager default installation)
Search paths where Audacity looks for LV2 plug-ins may also be specified by setting the LV2_PATH environment variable. The path listed below is legitimate.
  • $HOME/.lv2:/usr/local/lib/lv2:/usr/lib/lv2 (assuming $PREFIX is /usr/local as it should be by default)

Then use Effect > Add / Remove Plug-ins... to enable the LV2 effects and load them into Audacity, For details see Plug-in Manager: Effects, Generators and Analyzers.


Installing LADSPA plug-ins

Advice LADSPA has been superseded by LV2 and most if not all LADSPA plug-ins are ancient and are no longer maintained.
The LADSPA plug-in architecture which was originally developed on Linux. Audacity supports both LV2 and LADSPA effects on GNU/Linux. You can download and install a set of over 90 LADSPA plug-ins for all operating systems. You can then choose which LADSPA plug-ins to enable in the Plug-in Manager: Effects, Generators and Analyzers dialog.

LADSPA plug-ins can be installed for all users by putting the plug-ins into the Audacity "Plug-Ins" folder:

  • /usr/share/audacity/plug-ins if Audacity was installed from a repository package
  • /usr/local/share/audacity/plug-ins if you compiled Audacity from source code.

These locations are usually set as read-only, so the plug-ins will need to be copied as root (for example, by issuing an appropriate root command in the terminal, or by using the terminal to open a file manager application with root permissions).

To enable the new effects so they are available in the Audacity menu, use the Plug-in Manager: Effects, Generators and Analyzers dialog.

Audacity can also load LADSPA plug-ins from other system and user locations including:
  • All paths specified by the LADSPA_PATH environment variable
  • ~/.ladspa (plug-ins can be added to here with standard user permissions)
  • /usr/local/lib/ladspa
  • /usr/lib/ladspa
  • $LIBDIR/ladspa
  • ~/.audacity-data/Plug-Ins (deprecated).
Audacity installed from a repository package or compiled from source should automatically find LADSPA plug-ins installed in /usr/lib/ladspa. This may not be the case if you are compiling older source code. If necessary you can set an environment variable to indicate to Audacity where LADSPA plug-ins are installed. For Debian-based distributions this can be done by entering the following code at the command prompt (change <user> to your account username):
export LADSPA_PATH=$LADSPA_PATH:/home/<user>/.ladspa:/usr/local/lib/ladspa:/usr/lib/ladspa

If you wish this path to be set each time you boot, the LADSPA_PATH environment variable may be added to ~/.profile or this file may be created if it does not exist. An example of how to add the LADSPA_PATH environment variable:

LADSPA_PATH=$LADSPA_PATH:/home/<user>/.ladspa:/usr/local/lib/ladspa:/usr/lib/ladspa
export LADSPA_PATH

For OpenSuse 64, LADSPA plug-ins may be found in /usr/lib64/ladspa. This path can be set by adding the following line to your /etc/environment file:

LADSPA_PATH=/usr/lib64/ladspa

LV2 and Vamp plug-ins cannot be placed in the Audacity "Plug-Ins" folder or your .audacity-files folder. LV2 plug-ins should be installed by placing the complete .lv2 folder (not the individual files in that folder) in the root of ~/.lv2, /usr/local/lib/lv2, /usr/local/lib64/lv2, /usr/lib/lv2 or /usr/lib64/lv2. Alternatively the environment variable may be set as in this example:

export LV2_PATH=$HOME/.lv2:/usr/local/lib/lv2:/usr/lib/lv2


Installing Vamp plug-ins

Vamp plug-ins are usually for analyzing audio so will appear under Audacity's Analyze Menu. You can do interesting things like attempt to track beats, note pitches, chords or frequencies. Any Vamp plug-ins whose output is suitable for a label track should work in Audacity on GNU/Linux. To add a new Vamp analysis tool, add the plug-in's DLL, DYLIB or SO file and any supplied category or RDF files to any of the Vamp search locations then enable the tool in the Plug-in Manager: Effects, Generators and Analyzers dialog.

Vamp plug-ins may be installed in

  • ~/vamp
  • ~/.vamp
  • /usr/local/lib/vamp
  • /usr/lib/vamp.

Alternatively the VAMP_PATH environment variable may be set to any of those specified VAMP installation directories. Vamp plug-ins will normally be placed in the Analyze Menu of Audacity.


Installing VST plug-ins

Advice VST plug-ins made for Windows or macOS will not work on Linux without additional software such as wine. Although some VST effects are built for Linux and run natively, if an LV2 version is available then the LV2 version is usually the better option.

Audacity supports some VST effect plug-ins on Linux including "shell" VSTs that host multiple VST effects. Very few VST effects are available through official distribution repositories, so follow the vendor's instructions for installation.

Audacity can load VST plug-ins from several system and user locations including:
  • All paths listed in the "VST_PATH" environment variable
  • ~/.vst (plug-ins can be added here with standard user permissions)
  • LIBDIR/vst (where LIBDIR is defined at build time)
  • /usr/lib/vst
  • /usr/local/lib/vst
  • ~/.audacity-data/Plug-Ins (deprecated).

All the directories where you can place VST plug-ins are searched recursively, which means that plug-ins that are inside their own folder in that directory should still be found by Audacity.

When installed, the VST effect must be enabled in Audacity using the Effect > Add / Remove Plug-ins... menu item. This opens the Plug-in Manager: Effects, Generators and Analyzers dialog where you can select and enable the new effects then click OK to load them. Next time you launch Audacity the enabled effect(s) will be cached and you will not need to re-enable them.

Advice The list of effects in the dialog will include any detected VST instrument (VSTi) plug-ins (such as synths) and any real-time VST effects that are capable of changing audio data while it is being written to disk. Neither of these are yet supported and they will not load even if you enable or re-enable them in the dialog.


Why do some VST plug-ins not work or display incorrectly?

Audacity will by default display VST effect plug-ins with a full graphical interface where the plug-in supplies this.

VST instruments (VSTi) (such as synths) and real-time VST effects (that change the audio data while it is being written) are not yet supported. These will not load even if you enable or re-enable them in the Plug-in Manager: Effects, Generators and Analyzers dialog. VST 3 plug-ins are not supported.

If any plug-in displays incorrectly, you can use the Manage button Manage button icon W10.png in the effect's dialog then choose Options... to open the VST Effect Options for that effect. Then remove the checkmark from the "Enable graphical interface" checkbox unchecked checkbox Enable graphical interface and click OK. When you reopen the effect it will display a simpler tabular interface.

Advice On GNU/Linux, 32-bit systems will have 32-bit versions of Audacity which will not see 64-bit VST plug-ins. 64-bit systems will have 64-bit versions of Audacity which will see 64-bit VST plug-ins but will not see 32-bit plug-ins.

If you experience a problem with a specific VST effect plug-in in Audacity, please contact us.


How can I solve Audacity crashing after I add a plug-in?

Please see this FAQ

If you discover a specific plug-in that misbehaves in Audacity, please let us know via the Audacity forum. Please include any available Debug report that Audacity generates.

This Wiki page also has some information about Plug-ins that crash Audacity or fail to work properly in Audacity.


Links

>  Installing and updating Audacity on Linux