Automatic Crash Recovery

From Audacity Manual

Jump to: navigation, search


In the event of a crash while Audacity has unsaved data (such as a recording that has not yet been saved as a project, or an existing project with unsaved changes), Audacity will attempt to recover that data on next launch from an autosave recovery file.

If there were no unsaved changes at the time of the crash, there will be no recovery dialog - all you need to do is re-open the saved AUP file.

CrashRecovery.png
The project name in the list of recoverable projects includes the date and time of the autosave file, preceded by either the name of the project or by "New Project" for a project that was never saved as an .aup file.

Automatic Crash Recovery

  • Quit Audacity Exits Audacity without any changes. The Automatic Crash Recovery dialog will reappear next time you launch Audacity.
  • Discard Projects Discards the unsaved data for all projects. You will receive a prompt asking if you are sure this is what you want to do. If you confirm that want to discard all projects, they will not be recoverable later.
  • Recover Projects Attempts to recover the unsaved data for all projects, and load the recovered waveforms. If there are multiple unsaved projects, each will recover into their own project window. Note that the project history is not recoverable, so you can only recover to the project state at or just before the crash. You also cannot recover the text contents of a label whose text was being added at the time of the crash or where there was no action that triggered autosave after closing the new label.

Note that it is common if there are unsaved changes at the time of the crash for Audacity to warn of "file inconsistencies" when recovering the project. This usually means merely that there are "orphan block files" in the data that were there to enable undo or redo of a project action but which are now superfluous to the recovered project. If this was the case, you would see a note on opening Help > Show Log... that orphan files would be deleted on saving the project, but no warnings about other kinds of file error.

Warning icon
  • After recovery, the data is still in unsaved state. If the recovery appears correct, use File > Save Project to save the recovered project immediately. If the project is not saved when you exit, Audacity will prompt if you want to save the changes. If you choose not to save, all unsaved changes will be deleted and not recoverable.
  • If the recovered project appears incorrect, for example with silenced audio, do not save the project in incorrect state and do not close it and discard changes.
    1. Open Help > Show Log... and copy the errors shown - typically these would list "missing data block files".
    2. Force quit Audacity in the operating system's task manager to keep the autosave file and audio data safe, and search your computer or use a data recovery program to locate any files that were noted as missing.
    3. If you can restore these files to the location shown for them in the log, then you should be able to re-open Audacity and recover correctly.

Manual Recovery

If the Automatic Crash Recovery does not appear after a crash with unsaved changes, or the recovered audio cannot be corrected by searching for files, it may be possible to recover a single, unedited mono recording using crash recovery tools written for previous versions of Audacity. Stereo or edited audio is unlikely to be recovered in the correct sequence.

  • In order to use the crash recovery tools, it is essential to rename the unsaved .au files to a consecutive alphanumeric sequence. See "Recovering crashes manually" for detailed help.
  • If you had never saved a project before the crash, the .au files will be in Audacity's temporary folder, whose location can be found by looking in Directories Preferences.
  • If you had saved the project previously, the .au files will be in the _data folder inside the directory containing the .aup project file.
If manual recovery produces a poor result, check if you have an earlier saved state of the project to go back to whose audio would at least be correct. It is always a wise precaution to backup a project periodically to separately named AUP files as an insurance against crashes. See "How can I backup my Audacity Projects?" for how to do this.
Views
Useful External Links