Menu Reference

From Audacity Development Manual
Jump to: navigation, search
Many commands in Audacity appear in one of the menus and are documented on the following pages. Other functions can be found in Toolbars or run by using the appropriate keyboard shortcut listed in Keyboard Shortcut Reference. Shortcuts can be changed or added in Keyboard Preferences.

The Menu bar

Image of the Menu bar as it appears on Windows
The File Menu provides commands for creating, opening and saving Audacity projects, importing and exporting audio files and performing batch operations using ChainsThe Edit Menu provides standard edit commands (Undo, Redo, Cut, Copy, Paste and Delete) plus many other commands specific to editing audio or labelsSelect Menu has commands that enable you make selctions of tracks or parts of thetracks in your project.View Menu has commands that determine the amount of detail you see in all the tracks in the project window. It also lets you show or hide Toolbars and some additional windows such as Undo HistoryTransport Menu commands let you play or stop, loop play, scrub play or record (including timed and sound activated recordings)Tracks Menu provides commands for creating and removing tracks, applying operations to selected tracks such as mixing, resampling or converting from stereo to mono, and lets you add or edit labelsGenerate Menu lets you create audio containing tones, noise or silenceAudacity includes many built-in effects and also lets you use a wide range of plug-in effectsThe Analyze Menu contains tools for finding out about the characteristics of your audio, or labeling key featureThe Help Menu lets you find out more about the Audacity application and how to use it, it also includes some more advanced tools such as for taking Audacity screenshots, or viewing log messages generated by the applicationThe Extra menu provides extra Toolbar functionality enabling keyboard shortcuts to be assignedThe Extra menu provides access to additional Commands that are not available in the normal default Audacity menusMenu Toolbar.png


Click for details
Click on the image to learn more



Menu What you'll find there
Audacity (Mac Only) About Audacity, Preferences, System Services, Show and Hide Audacity and other applications, and Quit.
File Working with Audacity project files and other audio files.
Edit Altering the audio in your project.
Select Making selections of tracks, or within tracks, in your project.
View Change Zoom levels. Show clipping, Undo History, Mixer Board, Toolbars and Karaoke window.
Transport Control recording and playback.
Tracks Adding, aligning and labeling audio tracks.
Generate Creating new audio in your project. Audio generating plug-ins will also appear here.
Effect Processing the audio in your project. External Effects plug-ins will also appear in this menu.
Analyze Analyzing the audio in your project. External plug-ins that act on audio but do not produce audio output will appear here, as well as tools like Silence Finder and spectrograms.
Window (Mac Only) Minimize and zoom windows, choose the project window to bring to the front.
Help Short and full Help; capture Audacity screenshots; download current Audacity; audio device information; show the Log and generate support data; Audacity version number, license and build information.


The extended Menu Bar

There is an additional menu item in the Menu Bar, called Extra, that is hidden by default. It can be turned on at View > Extra Menus (on/off) or the Interface pane of Preferences.

The Extra menu adds access to many less frequently used commands. These are particularly useful to visually-impaired or motion-impaired users, but others may find them useful too.

Image of the Extended Menu Bar as it appears on Windows
The File Menu provides commands for creating, opening and saving Audacity projects, importing and exporting audio files and performing batch operations using ChainsThe Edit Menu provides standard edit commands (Undo, Redo, Cut, Copy, Paste and Delete) plus many other commands specific to editing audio or labelsSelect Menu has commands that enable you make selections of tracks or parts of the tracks in your project.View Menu has commands that determine the amount of detail you see in all the tracks in the project window. It also lets you show or hide Toolbars and some additional windows such as Undo HistoryTransport Menu commands let you play or stop, loop play, scrub play or record (including timed and sound activated recordings)Tracks Menu provides commands for creating and removing tracks, applying operations to selected tracks such as mixing, resampling or converting from stereo to mono, and lets you add or edit labelsGenerate Menu lets you create audio containing tones, noise or silenceAudacity includes many built-in effects and also lets you use a wide range of plug-in effectsThe Analyze Menu contains tools for finding out about the characteristics of your audio, or labeling key featureThe Help Menu lets you find out more about the Audacity application and how to use it, it also includes some more advanced tools such as for taking Audacity screenshots, or viewing log messages generated by the applicationThe Extra Menu provides access to Toolbar operations that are not available in the default Audacity menusThe Extra Menu provides access to commands for track focus and cursor movement that are not available in the default Audacity menusMenu Toolbar Extra.png


Click for details
Click on the image to learn more



Menu What you'll find there
Extra The Extra menu provides access to Toolbar operations and to extra commands for track focus and movement of the editing or playback cursor that are not available in the default Audacity menus. These will be of most interest to visually-impaired users or those who have difficulty using the mouse.

Shortcuts can be assigned to these commands if required.

If you only require regular access to a small set of these commands you can set shortcuts for them and leave the extra menus hidden.