Select Menu: Clip Boundaries

From Audacity Development Manual
Jump to: navigation, search


A set of commands to enable you to make selections based on any Clips that you may have in the project.
Click, or hover, on any menu item in the image to read about that command.  Skip the image
Edit MenuSelect MenuView MenuTransport MenuTracks MenuGenerate MenuEffect MenuAnalyze MenuHelp MenuExt-Bar MenuExt-Command MenuMenu BarSelects all of the audio in all of the tracksDeselects all of the audio in all of the tracksFor extending a selection to more tracksFor modifying, saving and restoring a selectionFor making a selection of a frequency rangeFor modifying a selection, taking account of clipsSelects from the position of the cursor to the previously stored cursor positionStores the current cursor position for use in a later selectionMoves the edges of a selection region (or the cursor position) slightly so they are at a rising zero crossing pointSelects from the current cursor position back to the right-hand edge of the previous clipSelects from the current cursor position forward to the left-hand edge of the next clipMoves the selection to the previous clipMoves the selection to the next clipSelect-Clip BoundariesMenu.png

Previous Clip Boundary to Cursor  

Previous Clip Boundary to Cursor and the three related commands below Cursor to Next Clip Boundary, Previous Clip and Next Clip use the clips in the selected track or tracks. If no tracks are selected, the clips in all tracks are used.

Selects from the current position of the editing cursor or selection backwards to the previous clip boundary, so extending the selection with each use to include further clips (or blank space) until the start of the track is reached.

Example:
Starting with this selection ...
SelectMenuClipBoundaries InitialSelection.png
after the first command the selection is extended from the editing cursor position to the start of the clip:
SelectMenuClipBoundaries PrevToCursor 1.png
after the second command the selection is extended to the end of the previous clip:
SelectMenuClipBoundaries PrevToCursor 2.png
and after the third command the selection is extended to the start of the previous clip:
SelectMenuClipBoundaries PrevToCursor 3.png

Cursor to Next Clip Boundary  

Selects from the current position of the editing cursor or selection forwards to the next next clip boundary, so extending the selection with each use to include further clips (or blank space) until the final clip is reached.

Example:
Starting with this selection ...
SelectMenuClipBoundaries InitialSelection.png
after the first command the selection is extended from the editing cursor position to the end of the clip:
SelectMenuClipBoundaries CursorToNext 1.png
after the second command the selection is extended to the start of the next clip:
SelectMenuClipBoundaries CursorToNext 2.png
and after the third command the selection is extended to the end of the next clip:
SelectMenuClipBoundaries CursorToNext 3.png

Previous Clip  Alt + P

Moves or creates a selection so as to fully select in the current clip where the editing cursor or selection is. However if that cursor is already exactly at the start of the current clip or if the current clip is already fully selected, this command will fully select in the previous clip. Further use of Previous Clip then fully selects in the previous clip until the first clip is reached.

Example:
Starting with this selection ...
SelectMenuClipBoundaries InitialSelection.png
after the first command the clip containing the cursor is selected:
SelectMenuClipBoundaries Previous 1.png
after the second command the previous clip is selected:
SelectMenuClipBoundaries Previous 2.png
Subsequent commands will do nothing since the first clip in the track is selected.

Next Clip  Alt + N

Moves or creates a selection so as to fully select in the next clip. If the editing cursor is exactly at the start of a clip, this command selects all of that current clip.

Example:
Starting with this selection ...
SelectMenuClipBoundaries InitialSelection.png
after the first command the next clip is selected:
SelectMenuClipBoundaries Next 1.png
after the second command the next clip is selected:
SelectMenuClipBoundaries Next 2.png
Subsequent commands will do nothing since the last clip in the track is selected.


To move the editing cursor to the start of the next or previous clip without selecting its audio, see the Transport > Cursor to commands for Previous Clip Boundary and Next Clip Boundary.

<  Back to: Select Menu