Tutorial - Looping

From Audacity Manual

Jump to: navigation, search

This page provides tips on how to make an audio loop with Audacity.


  1. Creating an audio loop
  2. Using loops in Audacity
  3. Exporting Loops
  4. Using Timeline Quick-Play to create loops

Creating an audio loop

To create an audio loop from an audio track, the first step is to find a suitable section. Ideally the sound will be reasonably constant for as long as possible. Looping is much easier with mono tracks, so if you have a stereo recording but a mono track would be sufficient, the track could first be converted to mono using Tracks > Stereo to Mono.

Loop selection.png

The start of the selection should match (look like) the end of the selection as closely as possible and both selection edges should be positioned so that the blue line of the waveform seems to cross the selection edge at zero amplitude (where the horizontal line appears).

There are items in the View menu that allow jumping from one end of the selection to the other while zoomed in:

To look for appropriate loop points, zoom in horizontally on the start of the selection and then on the end of the selection. To zoom, place the mouse pointer at the selection edge and scroll with the wheel or ball. Drag the selection edges leftwards or rightwards as necessary so as to find loop points that have a similar shape, amplitude and slope so that the end of the loop may flow smoothly into the start of the loop. It may also be useful to zoom in on the vertical scale to left of the waveform, as shown in the following images:

Beginning of the loop selection
Loop start.png
End of the loop selection
Loop end.png

To avoid clicks (glitches) it can often help to use Edit > Find Zero Crossings so as to ensure the start and end of the selection lie accurately on a zero crossing point. In the image below, the sample at the end of the selection (as shown by the dot) is at 0.0 amplitude according to the vertical scale on the left.

Zero crossing point

The loop may be tested using Loop Play (SHIFT + SPACE).

Using loops in Audacity

If the loop is to be used in Audacity, the selection may be trimmed: CTRL + T. The loop may be repeated using Copy and Paste, though it is usually more convenient to use the Repeat function: Effect > Repeat....

Exporting Loops

The selection may be exported using File > Export Selected Audio....

The lossless PCM WAV format is the best format for loops. Choose "WAV (Microsoft) signed 16-bit PCM" when exporting. Many lossy, size-compressed formats like MP3, WMA and ADPCM WAV suffer from added silence at the the start or end of the file or other issues that do not respect the exact length.

If a lossy compressed audio format is required then OGG Vorbis may be a better choice as it does not suffer from length issues.

Using Timeline Quick-Play to create loops

The above process can be aided by using the Timeline to help create a seamless loop:

  1. Ensure that Quick-Play is enabled in the Timeline right-click context menu.
  2. Select "Enable dragging selection" in the Timeline right-click context menu.
  3. Make an approximate selection of the audio to be looped.
  4. Shift + Left-Click within the selection to loop play the selection.
  5. Shift + Left-Click and drag the start/end of the selection as necessary to adjust the selection closer to "seamless" looping positions.
  6. If necessary, zoom in on the start / end positions to make adjustments to the play region and selection.
  7. Note that if zooming in causes the selected region to extend beyond the visible track area, Audacity will, by default, cause the waveform to scroll. The scrolling behavior can be disabled from the Timeline right-click context menu.
  8. While zoomed in, use CTRL + [ and CTRL + ] to view the start / end of the selection.
  9. If a long selection is being looped, playback may be stopped at any time by pressing SPACE, then looped Quick-Play may be restarted from a short way before the end of the selection with Shift + Click on the Timeline
  10. Then Optionally label the loop region (use CTRL + B)

When the selection loops seamlessly, playback may be stopped (using Stop button or its SPACE shortcut) and the selection exported or trimmed as required (use CTRL + T to trim to the selection).

Seamless loops should normally be exported in a lossless format such as WAV. Note that seamless loops should NOT be exported in MP3 format because encoder/decoder overall delay is not defined, which means there is no official provision for gapless playback.

If a compressed file format is required, try OGG Vorbis (though understand that because OGG Vorbis is a lossy format, the encoded audio is not exactly identical to the original audio). OGG Vorbis loops will generally perform acceptably provided that the start / end of the loop are at zero crossing points.

Finding free loops created by others


Useful External Links