Copy and Paste a section of audio

From Audacity Development Manual
Jump to: navigation, search

Copying and pasting a section of audio from one track to another is a useful way to paste the good sections of one take over the bad sections of another take. In this example the track with the "good" section is the "Source" track and the track with the "bad" section is the "Target" track.

Select the required audio

Use the Selection Tool The Selection tool to select a section of audio from the source track (the source and target tracks are labeled Source and Target in the examples.)


To make sure your selection includes exactly the section of audio you want, you can use the zoom tools under the View menu to zoom in to the beginning and end of your selection and select the exact samples you want. To prevent "popping" sounds in your final audio track, try to select a section of audio that starts and ends at the 0.0 line.


You'll want to select a section of audio that ends at the 0.0 line as well.


Now that you have a well-formed selection, you can copy and paste it to the target track.

Zoom out so you can see your entire selection.


Make the copy

Copy the selected audio to the Audacity clipboard by clicking on Edit > Copy or press the shortcut Ctrl + C.

Apply the paste

Hold the Ctrl key and click in the Track Control Panel of the target track with the channel, rate and format information. This selects the target track without changing any of its controls and extends the selection into the target track. Then Ctrl-click in the Track Control Panel of the source track to deselect it.


Select Edit > Paste from the Edit Menu or press the shortcut Ctrl + V.

You can also get "popping" if the target track hops from 0.0 before and after the audio you paste, so you may want to write down your Selection Start, End and Audio Position so you can adjust gaps before and after your pasted audio, with either the Draw Tool Draw-button.png or Fade Out from the Effect Menu.

Pasting into a new track

If you want to create a new track and paste into that, the paste will automatically create a new mono or stereo track as appropriate, with the audio starting at time zero, if you:

  • Paste into an empty project window
  • Click in the gray background underneath the last track in the project to deselect all the tracks, then paste.
  • You can paste from a mono track into a stero track - the mono audio will be replicated in both stereo channels.
  • You cannot paste from a stereo track into a mono track. (You will get an error message if you try to do this.)

If you want the paste to start at other than time zero you must first use Tracks > Add New > Mono Track (or Add New > Stereo Track), place the cursor where you want to paste, then make the paste.