Playback Tips

From Audacity Development Manual

Jump to: navigation, search

This page explains how to view and adjust playback volume, and achieve smooth playback quality.

For tips on how to navigate the waveform or tracks (including moving the playback position), and how to find and mark edit points, see Navigation Tips.

Contents

Viewing and adjusting playback volume

The volume of audio playback (output) which will be saved in an Audacity project or exported as a finished audio file can be seen in the Playback Meter:

Playback Toolbar in use - clipped signal.png

If Meter Toolbar is not visible, go to View > Toolbars and enable the Meter Toolbar.

  • This volume level can be modified with the -....+ gain slider on the Track Control Panel of each track. Note this does not affect the volume level stored in the audio data and represented in the waveform, but is a modification on top of it. Avoid accidentally moving the gain slider away from center when exporting an audio file. If the slider goes too far to right, this may lead to excessive volume and therefore distortion in the exported file. If it goes too far to left, the file may not be audible.
  • The left-hand playback (output) volume slider on the Mixer Toolbar controls only the volume at which you hear the tracks in Audacity. It does not affect the Playback Meter. Only moving the gain slider, or changing the track volume by editing will affect the meter.
  • If multiple tracks are played simultaneously, their volume is combined. You may need to move the gain sliders leftwards on each Track Control Panel to reduce the combined volume. To keep the current balance between all the tracks, move each slider to left by the same amount. To judge if you have distortion, look at the Playback Meter. If the colored bars are changing to red and hitting the right-hand edge of the scale and so bringing on the red hold lights to right of the meter, you have distortion in the output and must reduce the gain.
  • The Playback Meter Toolbar can be resized, making it bigger provides more detail and make it more accurate and easier to use. See this page for details of how to do this.

Smooth Playback

A project with a track lasting several hours or multiple tracks of any length will eat a lot of computer resources. To play many tracks simultaneously you will likely need far in excess of Audacity's stated minimum requirements (mentioned on the download page for each operating system). Think of 500 MB RAM and 1 GHz processor speed upwards, depending on the number of other running applications and processes, and the number and length of tracks you have. Generally the more RAM you have the better.

Try all these other tips if you are having problems with uneven playback:

Computer Resources

  • Try exiting and restarting Audacity or rebooting
  • Close as many other applications as possible
  • Set the project rate (bottom left of the Audacity screen) to 44100 Hz or 48000 Hz. Higher rates will give the computer more work to do and will have to be resampled if your sound device does not support those rates, leading to worse quality
  • Go to the Quality tab of Prefences and set the Default Sample Format to 16-bit, which halves the work the computer needs to do to play the tracks
  • Zoom out using View > Zoom Out (or CTRL + 3)
  • Don't use a network drive for your Audacity temporary folder or project _data folder, or for storing uncompressed files for import into Audacity - it will be too slow
  • On Windows, keep your drives defragmented, so the data files can be accessed quickly and efficiently. Instead of the Windows defrag utility, try fragdown.This will give you a replacement shutdown button that will automatically defragment all detected disks, then shut the system down.
  • Consider enabling DMA on your drive if it is not already
  • Ensure your sound device drivers are up to date
  • Consider reinstalling Windows if updating your sound drivers does not help - Windows problems can lead to erratic sound behavior especially when the CPU is busy
  • See the tips at Managing Computer Resources and Drivers in the Audacity Wiki.

Managing Tracks

  • Muting the tracks you do not need to hear may help slightly
  • Select areas of tracks rather than the whole, in order to hear what a mix sounds like
  • If you need separate Audacity tracks, select all of each track in turn (by clicking in the Track Control Panel where the mute/solo buttons are) and Tracks > Mix and Render - this may help playback by ordering the audio data files more logically
  • Consider mixing some tracks together (again with Tracks > Mix and Render as soon as you no longer need them to be separate
  • Consider cutting tracks you are not currently working with into a new project window (File > New). This will make a big difference.
  • If you are recording sections one at a time, use Pause in the same Audacity session to keep the recording on one Audacity track
  • You can always hold SHIFT and click RECORD (shortcut SHIFT + R) to record at the end of an existing track, even when re-opening a saved project
  • On slower machines, try right-clicking over the Playback Meter Toolbar, hit "Preferences" and choose a lower refresh rate
  • Try increasing the default "Audio to buffer" setting of 100 milliseconds at the Recording tab of Preferences. This might lead to smoother playback on slower machines. The disadvantage would be that playback would take longer to start, and there would be more delay in laying down and monitoring recordings.
Views

Donate securely by PayPal, using your credit card or PayPal account!

Useful External Links