Managing Audacity Projects

From Audacity Development Manual

Jump to: navigation, search


All editing in Audacity is done as a project. It is important to note that a project is not a single audio file but a complex set of files managed by Audacity.
  • Audacity projects have a top-level AUP file and a related folder containing the sound files (the audio data). The AUP is not a sound file, it is merely a list of instructions that tell Audacity how to construct the project from the sound files in the folder. Audacity projects can only be used by Audacity.
  • To make an audio file (such as WAV or MP3) for playing on your music player, or for use in other applications, use one of the Export Audio commands.

Contents

  1. Structure of an Audacity project
  2. Saving an Audacity Project
  3. Opening an Audacity Project
  4. Project Dependencies
  5. Moving or sending an Audacity project
  6. Backing up Audacity projects
  7. Deleting an Audacity project
  8. Autosave and Recovery
  9. Disk space usage


Structure of an Audacity project

The Audacity Project Format stores all Audacity tracks and clips, labels, amplitude envelope points, gain and pan data, together with other project data. The audio can be a recording, imported files, generated audio or a mixture of any of those. Projects are a convenient way to save your extended multi-track piece and come back to it later exactly as you left off.

Audacity's project format is not compatible with and cannot be opened in any other audio application.

The structure of a saved Audacity project is:

  • An AUP project file - the name of the project followed by ".aup", for example "my_song.aup"
  • A _data folder with the same project name and in the same folder as the .aup file, for example "my_song_data"
  • Within that _data folder, a sub-folder structure with lots of little AU files which are individual segments of the audio data.
Note that default behavior on Windows and Mac is to hide certain file extensions ; if this applies, the .aup file will only appear as "my_song" in the computer. On Windows, the .aup extension will be hidden if Audacity was installed from the .exe installer and "Hide file extensions for known file types" remains checked in Windows Explorer. You can unhide extensions on Windows by following these instructions.

The project file describes how Audacity links these AU files together to make up the clips and tracks in the project; it also contains gain, pan and envelope information, data to manage the waveform display and carries links to any dependent audio files being read directly from their source location.

The AUP file is in XML format and can be opened in a text editor if required. The AU files are stored in a lossless, uncompressed format. Their default size is 1 MB or less. This Audacity Project Format is designed to make editing audio faster in Audacity. By updating individual AU files during editing, Audacity can change audio or move it around in the project without copying large quantities of data from one place to another.

The four rules for keeping your Audacity Project happy:
  1. When importing an uncompressed audio file with the "Read uncompressed file directly from the original (faster)" option checked in Import / Export Preferences never move, rename or delete that file unless you first copy it into the Audacity project. See File > Check Dependencies for more information.
  2. Never move, delete or rename any of the files or folders inside the _data folder.
  3. Never rename the AUP file or the _data folder by hand.
    If you want to rename your project (for example, to save a snapshot at a particular point), use the File > Save Project As... command.
  4. Always keep the AUP file and the _data folder together in the same directory (folder).


Saving an Audacity Project

A saved Audacity Project can only be opened and used by Audacity. If you want an audio file that will play on your music player or to burn a CD, use an Export command.

The benefits of saving an Audacity Project are:

  • Saving a project lets you save unfinished work and re-open it later in Audacity exactly as it was, with all edits and recorded/imported tracks preserved. Note carefully that the Undo history is not saved with the project and so the project history starts afresh when you re-open the project later.
  • Audio data is always preserved in lossless quality. This is useful if you have already exported to a lossy audio format like MP3 but decide to edit the project further. Editing and re-exporting the project saves the additional quality loss of re-editing the previously exported MP3.
  • No need to re-import or re-record files

There is no need to Save a project, unless required, as it is possible to work with temporary project files and then just use File > Export Audio... to export the required audio files. If the project is not saved, the necessary audio data is stored in the temporary folder specified in the Directories section of Preferences until exiting the application. At that point, Audacity offers the choice of saving a project or not.

There are two main commands for saving projects:

  • File > Save Project saves a standard project as an AUP project file (a file with ".aup" after its name) and a _data folder containing the actual audio. If the project does not have any unsaved changes (for example, if the project is empty or you just saved it), "Save Project" will be grayed out.
  • File > Save Project As... similarly saves a standard project as an AUP file and _data folder. It is for saving an empty project or to save an existing Project to a new name to make a copy of the project in its current state then continue working on that copy.

As with saving any type of file, certain characters cannot be used in the name of the AUP file if they are reserved for the operating system. See our information on forbidden characters. When saving an Audacity project it is normally easiest to use the File > Save Project command, which has a default shortcut of CTRL + S (or COMMAND + S on Mac). If you save a project again having made further changes to it, "Save Project" then updates the AUP file and _data folder silently without bothering you with prompts.

Long projects contain a lot of data. Ensure the project is fully saved before exiting Audacity or shutting down the computer. If there is a progress dialogue for saving the project, wait for it to complete before shutting down. The Status Bar at the bottom shows a message when the project has been saved.

Saving copies of projects

"Save Project As" is the safe and recommended way to make a copy of a project with a new name or location. This could serve either as a single backup copy of the project, or as one of several incremental copies of the project in the state it had at a particular date and time. If you "Save Project As" with a new name, the project window then displays the project name you just "saved as". The project window displaying the project as previously named is closed in its last saved state, but can be reopened as required.

Warning icon You should never use the operating system's copy and paste to make a copy of the project AUP file and _data folder in the same folder as the original project. If you must make a copy by hand, save and close the project first then copy the AUP file and _data folder and paste these into a different folder. This ensures the original file and folder names are retained.

Saving a compressed copy of Project

If you need to save space (for example to send a project over the internet) you can save a compressed version of your project by using File > Save Compressed Copy of Project....

This will save a copy of your project in the lossy, compressed Ogg Vorbis format, each track being saved as a separate OGG file.


Opening an Audacity project

When opening an Audacity project always use File > Open or File > Recent Files to open the "my_song.aup". Do not attempt to open, import or manipulate any individual AU files.

Audio which was not saved as an Audacity Project will need to be imported using File > Import, File > Open or by dragging the file in. The Import command is used to import audio data into an already open project, whereas the Open command used on an external audio file either imports the file into the current project if it never contained any other tracks, otherwise imports it into a new project window. See Importing Audio for more information.

Older Projects
  • Audacity can usually open AUP files created in legacy Audacity 1.2.x, but saving the project will prevent it opening again in 1.2.x. Before opening the legacy AUP file, copy it and its _data folder and paste them into a different folder to make a backup. If necessary you can open the backup in Audacity 1.2.x, export each track as WAV then import the WAV files into current Audacity.
  • Projects created in legacy Audacity 1.1.x or earlier can only be opened by exporting each audio track as WAV in the legacy version of Audacity, then import the WAV files into the current version of Audacity.

Project Dependencies

When importing uncompressed audio files, such as WAV or AIFF, Audacity has an import preference that lets you save disk space and edit the files almost immediately by reading them directly from their original source location, rather than copying them into the project. In that case Audacity will reference the original file directly (but not make any changes to that audio file unless you export over it). If you import the files by reading them directly, you must not at that point rename, move or delete those original source files and must not modify them outside Audacity.

When you first import a file by any means, for example by using File > Open..., File > Import > Audio... or by dragging the file in, the preference is automatically set to "copy in" and a Warning dialog is presented explaining the difference between copy-in and read-directly and asking which method should be used for this import. You can opt for Audacity to use your current choice in future and not ask again, but you can change your choice at any time in Import - Export Preferences.

When a project is saved and the "faster" option has been chosen, Audacity will display a dialog box showing these dependencies and give the option of copying all of the audio data into the project. This makes the project independent of external audio files and makes it safe to delete, move, rename or modify the original audio files if necessary. The Projects Preferences settings can be modified so that Audacity will not ask when saving a project but will always either "never copy" the dependent audio files, or "always copy" them into the project.

At any time it is possible to click on File > Check Dependencies... to see if the project depends on any external files.

Import settings: "faster" versus "safer"

There are two settings that determine how Audacity imports a WAV or AIFF file.

  • Make a copy of the files before editing (safer): This is the default setting. Audacity copies in the entire audio data of files when importing them.
Choose this "Safer" option if:
  • Plenty of disk space is available and the time taken to import is not crucial
  • You want peace of mind that the project will never depend on other files
  • The Audacity project is to be opened on another computer or sent to someone else (if you only want to send an exported audio file to someone else, you do not need to choose "Safer").
  • Read the files directly from the original (faster): Audacity uses On-Demand Loading. This imports files much faster by only writing small AUF "summary" files that reference the imported file and so depend on that imported file remaining available. Audio data is only copied in for any parts of the file that you subsequently edit. If you apply an edit to the entire audio of the imported file, Audacity will at that point copy the entire audio data in, so providing you do not undo that edit of the entire audio, the project will henceforward no longer depend on the imported file.

    Note that if you overwrite a read-directly WAV or AIFF file by exporting to the same file name and location, Audacity renames the imported file with a suffix containing "-old" and a number, then this "-old" file becomes the dependent file for the project. Do not delete "-old" file(s) until you are happy with the exported file and no longer require the Audacity project.

Warning icon Do not choose the "Faster" option unless you completely understand the implications. If you move, rename or delete the imported file, the project data may be lost.

Moving, renaming or sending an Audacity project

Moving or renaming Audacity projects can be tricky due to their complex structure as described above. Any project can be moved on the same computer, or renamed, by making a copy of the project with the File > Save Project As... command.

  • Sending somebody just an AUP file does not send them an Audacity project - to do that you would need to send the _data folder containing the small AU files too.
  • For a simple single track project (that does not have gain or pan settings, or use an envelope to adjust the volume) one possible solution is to not move the project. Instead, use the File > Export Audio... command to export a WAV file. This WAV file can then be copied to another computer (such as by using a USB flash drive), then the File > Import command can be used to load the WAV file into an Audacity project. Alternatively the WAV file can be sent by email (if the WAV is not too large) or via a file sharing website to someone else who can import it into an Audacity project on their computer.
  • For a project that has multiple tracks, or a single-track project that has gain or pan settings or uses an envelope to adjust the volume of the track, the entire project will need to be moved. To move to a different location on the same computer, use File > Save Project As.... Save Project As can also be used to transfer the project to another computer on the same network, though this can be slow. If it is necessary to move the project by hand, save and close the project then move the AUP file <my_project_name>.AUP and the _data folder <my_project_name>_data to a different folder or computer. Ensure that the .AUP file and _data folder remain together in the new folder.
Warning icon Never rename a project by hand in any folder. Doing so will corrupt the project.
  • If moving the project to a different computer, the project must not depend on external audio files because the actual (absolute) path to these is stored in the AUP file. Use the File > Check Dependencies... command to check whether the project depends on any external files. If it does, the dialog box will give you the option to make a copy of those files within the project.
  • It can be difficult to email complex projects to others because of the size of the project data and because you must send a ZIP file containing AUP file and _data folder to ensure the project structure remains intact. If you do not mind sending slightly lossy audio in the project, the file size can be greatly reduced by zipping up a compressed copy of the project. Note that ZIP formats do not support reliable character encoding, so for the name of the project, labels, track names or metadata, only use A to Z or a to z characters, whole numbers (0 to 9), underscore or hyphen-minus (or use the NUMPAD_SUBTRACT key).

See also Sending your work to others and this FAQ.

Backing up Audacity projects

Regular backups should if possible be made to one or two devices other than the device the current project is stored on, as computer hard drives can fail, destroying all data. For example, backups could be made to another internal drive on the computer, or ideally to an external USB drive or uploaded to an online (cloud) storage service.

For advice on backing up Audacity projects please see this FAQ.

Deleting an Audacity project

There is no File > Delete Project command in Audacity; therefore to delete a project to free up disk space it is necessary to make the deletion manually. You will need to delete both the AUP file and its associated, identically named _data folder.

Note that this will not remove the listing of your project under File > Recent Files.... After deleting the project you can choose the AUP entry for that project in the Recent Files list in order to remove the entry.

Autosave and Recovery

As soon as you open a project window and change the window contents, whether this is a previously saved project or you are creating a new project, Audacity writes a temporary reference file for that project called an ".autosave" file. This allows Audacity to automatically recover unsaved changes in the event of a crash or power loss.

When you use File > Save Project or File > Save Project As... there are no longer unsaved changes, so the ".autosave" file is deleted until fresh unsaved changes are made. The file is stored in the "AutoSave" folder inside Audacity's folder for application data. The file is of identical internal structure to an AUP project file, but is not readable by a text editor.

Most changes you make to the audio data, such as adding or removing audio or applying an effect to it, trigger writing the ".autosave" file. A change to the position of the selection or editing cursor does not write to the ".autosave" file, and is not captured when closing the project, unless the project is already "dirty" (as shown by File > Save Project being clickable).

Disk space usage

This can be particularly important if you are editing a large project.

Audacity references the original audio material until you actually perform some kind of edit on it, such as cutting a piece away or using any effect on it. So if you Edit > Duplicate a selection, this doesn't actually increase the number of .au files in the _data folder, and doesn't increase disk space usage. Edit > Copy for example does increase the number of .au files, but this is so these files can be retained separately on the Audacity clipboard for Edit > Paste.

Once you perform an edit, the original unchanged audio is retained, along with the changed audio. This is so you can use Edit > Undo and Edit > Redo to try out edits and undo them if they do not sound as you wanted.

If you edit just a small selection in a track, only that small selection of changed data is written to disk. Nonetheless, this still represents a doubling of disk space usage for that selection, and a further edit on that selection (unless you first undo the previous edit) adds the same amount again, and so on. For example, a five minute stereo recording at default quality settings takes 100 MB of space. If you edit the whole length of that recording, disk space usage will increase to 200 MB.

If disk space is a problem while working on a project, you can use View > History... to discard Undo levels and reclaim disk space. Note that once you close the project by using File > Close or exiting Audacity, the audio data needed for Undo/Redo is discarded, so as to make project storage as economical as possible.

Any audio data placed on the Audacity clipboard by Cut or Copy is however retained until you exit Audacity itself.

Views

Donate securely by PayPal, using your credit card or PayPal account!

Useful External Links