Silence Finder and Sound Finder

From Audacity Development Manual

Jump to: navigation, search


Silence Finder and Sound Finder are two related tools which can useful to label the different songs or sections in a long recording, such as the tracks from an LP or cassette.

Silence Finder - Setting Parameters has more help on adjusting the Silence Finder slider settings.

After typing the name of the track or section in each label, File > Export Multiple... will export audio files in one process corresponding to each label's audio. See Splitting a recording into separate tracks.

Silence Finder...

Accessed by: Analyze > Silence Finder...
Silence Finder W10.png

Silence Finder divides up a selection by placing point labels inside areas of silence. Use this if you just want to split the recording into tracks at a specific point without removing the silences between them.

If labels are produced in the middle of album tracks, increase the silence level and duration. If some album tracks do not have a label between them, reduce the silence level and duration. See Setting Parameters for more help choosing values to place the labels correctly.

Warning icon If the selection ends with silence, the final label is not placed according to the "Label placement [seconds before silence ends]" setting but is placed after the start of the final silence according to the "Minimum duration of silence [seconds]" setting.

Sound Finder...

Accessed by: Analyze > Sound Finder...
Sound Finder W10.png

Sound Finder divides up a selection by placing region labels for areas of sound that are separated by silence. Use this to make the labels show the exact region of each track to be exported. This lets you remove some or all of the silence between the tracks.

If any album tracks have more than one label, increase the silence level and duration. If any labels extend into other album tracks, reduce the silence level and duration.

The buttons

Clicking on the command buttons give the following results:

  • Manage gives a dropdown menu enabling you to manage presets for the tool and to see some detail about the tool. For details see Manage presets.
  • Debug applies the effect to the selected audio with the current effect settings, but unlike OK the effect runs in debug mode. This is primarily of use when writing or editing Nyquist plug-ins.
    • In addition to the normal plug-in behavior, a "debug window" opens to display error messages, normally the debug window will be empty.
  • OK applies the effect to the selected audio with the current effect settings.
  • Cancel aborts the effect and leaves the audio unchanged.


Examples

Here is a stereo track with six songs. The entire project is selected prior to using the Analyze functions.

Silence-Sound Finder six songs.png

Example with Silence Finder

After running Analyze > Silence Finder... we can see that Audacity has identified the six songs, placing an "S" label just before the beginning of each song plus a seventh label at the end (as the final track ends in silence).

Silence Finder six songs shown.png

Example with Sound Finder

If instead we run Analyze > Sound Finder... on the same selected audio we can see that Audacity has again identified the six songs giving them numerical labels. The labels exclude a small amount of the gaps between the songs (seen most clearly between labels 5 and 6) so the lead-in and lead-out for each song would be shorter.

Sound Finder six songs shown.png

Links

|< Index of Effects, Generators and Analyzers

|< Analyze Menu

Views

Donate securely by PayPal, using your credit card or PayPal account!

Useful External Links