Apply Macro

From Audacity Development Manual
Jump to: navigation, search
Macros Palette automatically applies a series of preconfigured commands in a set order. The dialog allows you to select a Macro (which is a sequence of effect and/or export commands created using Tools > Macros then apply that Macro to either the entirety of the current project or to selected audio files in a single directory.
Bulb icon Effect presets: since it is quite possible to have just a single command in a Macro you can use Macros to store your regularly used effects along with your favored settings.
  • This Macros Palette is useful for presets for effects. It stays open after applying a Macro, and you can pick another and apply that.
  • If you want, the presets can also adjust the selection. See Macros Examples for some suggested examples of this.

Contents

  1. Macros Palette
  2. Select Macro
  3. Apply Macro to...
  4. The buttons
  5. Examples


Macros Palette

Accessed by:

  • Directly from the menu Tools > Apply Macros > Palette, or
  • Using the Shrink button in the Manage Macros dialog
MacrosPalette.png
Macros Palette showing several user-added Macros as well as the as-shipped "MP3 Conversion" and "Fade Ends" Macros

Once invoked, the Macros Palette window will remain on-screen, actively available, at all times unless and until you dismiss it or close Audacity.


Select Macro

In the "Macro" list, left-click on a Macro (or use Up or Down keyboard arrow) to select the Macro you want to apply.


Apply Macro to

Project

Use the Project button to apply the selected Macro to the current project.

The typical purpose of this option is effect automation - apply a sequence of effects to the project, using effect parameters and an order of applying the effects that you have found to work well for the type of audio you are processing. This saves time and provides consistency in your workflow.
Warning icon If you already have audio in the current project window, you must save and close that project using File > Close before applying a Macro to files.

The effects in the Macro are applied to the selected region of waveform in the selected audio tracks. Usually the selected Macro would not include an export command so as to use the greater flexibility of the Export Audio Dialog.

If an export command is included in the Macro, the entire project audio is exported irrespective of track or region selection. Therefore if the project contains multiple audio tracks, they will be mixed together, unless any of the tracks are muted on the Track Control Panel.

The exported files will be saved in a folder named "macro-output".

  • If the project has been Saved, then the "macro-output" folder will be in the same directory location as the project and the audio file name will be the same as the project name but with the extension appropriate to the export type.
  • If the audio in the project came from an imported file or files, the "macro-output" folder will be inside the directory from which the first file was imported. The original files are not altered.
  • If the project has not been saved and no audio has been imported, the normal Export Audio dialog will appear enabling you to choose the name and location of the exported file.
Bulb icon Macros will work on pre-existing selections you make in your project prior to running the Macro. But the selection can be over-ridden by your Macro itself as there are macro commands available to effect selections in the audio. In particular All(Select All) will select the entire project and Select which is parameterizable (see the provided Fade Ends Macro for an example where the first and last one seconds of the audio are selected for the fades).

Files...

Use the Files... button to apply the selected Macro to selected external audio files that are in a single directory. If you already have audio in the current project window, you must save and close that project using File > Close before applying a Macro to files.

The typical purpose of this option is batch processing - apply the Macro to multiple audio files so as to apply one or more effects to them, and/or convert them to another file format. You can convert from any file format supported by Audacity to WAV, MP3, OGG or FLAC.

Warning icon The selected Macro must include an Export step, otherwise the processed audio will not be retained.

The exported files will be saved in a folder named "macro-output" in the same folder that the original audio files came from. The original files are not altered.

You cannot process multi-channel audio files (for example, 5.1 surround sound files) using Macros, even if Import / Export Preferences has been set to "Use custom mix". Any multi-channel files you import will be mixed down on export.

  • A standard File Open dialog box will appear. Choose a directory then you can select one or any number of supported audio files in that directory, but not Audacity AUP project files. You cannot select files outside that directory, and files in folders inside that directory will not be processed. It is convenient therefore to first put all the audio files you want to process into one folder before applying the Macro.
  • After selecting the audio files you want to process, choose Open.
  • Each file will be imported into Audacity and processed, exported to the format you chose in the Macro, then the processed audio will be removed so as to clear the temporary disk space that had been used.
  • The exported files will be saved in a folder named "macro-output" in the same folder that the original files came from.
When a Macro is applied to files, the only option is to import and process the entire file. Thus the entire file will be exported unless an action or effect in the Macro (such as Cut or Truncate Silence) removes some audio.
Bulb icon It is recommended not to process more than 500 files at a time.


The buttons

Expand

Use the Expand to return to the full-size, full-function Manage Macros dialog.

The apply Macro buttons are also available on the Manage Macros dialog - so all Macro operations can be made from that full dialog.

Cancel to exit the dialog

To dismiss the dialog simply click on the Cancel button

Otherwise the dialog will remain open on the screen, but allowing you to perform other Audacity functions.


Macros Examples

See the Macros Examples page for examples of using Macros.


<  Manage Macros

|<  Back to: Macros