File Menu: Export

From Audacity Development Manual
Jump to: navigation, search
This enables you to Export audio from Audacity into audio file formats that can be read and played by other applications.

Additionally you can export label files or MIDI or save a compressed copy of your project in a set of Ogg Vorbis formatted files.

Please be aware that when using Export or Export Multiple Audacity will only export tracks that are not grayed-out by use of the Mute or Solo buttons in the tracks' Track Control Panels. So what you hear by previewing with playback prior to export is what you will get in the Exported audio file.
  • When using Export Selected Audio, however, Audacity will Export the selection from all selected tracks even if some if those tracks are grayed-out and inaudible on playback.
This menu has items to open, save, import and export files.The Edit Menu provides standard edit commands (Undo, Redo, Cut, Copy, Paste and Delete) plus many other commands specific to editing audio or labelsSelect Menu has commands that enable you make selections of tracks or parts of the tracks in your projectView Menu has commands that determine the amount of detail you see in all the tracks in the project window. It also lets you show or hide Toolbars and some additional windows such as Undo HistoryTransport Menu commands let you play or stop, loop play, scrub play or record (including timed and sound activated recordings)Tracks Menu provides commands for creating and removing tracks, applying operations to selected tracks such as mixing, resampling or converting from stereo to mono, and lets you add or edit labelsGenerate Menu lets you create audio containing tones, noise or silenceAudacity includes many built-in effects and also lets you use a wide range of plug-in effectsThe Analyze Menu contains tools for finding out about the characteristics of your audio, or labeling key featureThe Tools Menu contains customisable toolsThe Extra menu provides access to additional Commands that are not available in the normal default Audacity menusThe Help Menu lets you find out more about the Audacity application and how to use it.  It also includes some diagnostic tools.Creates a new empty project window, to start working on new or imported tracksPresents you with a file selection dialog box to open filesLists the full path to the twelve most recently saved or opened projects or most recently imported audio filesCloses the current project window, prompting you to save your work if you have not savedVarious ways to save a projectFor exporting audio filesFor importing audio files or label files into your projectOpens the standard Page Setup dialog box prior to printingPrints all the waveforms in the current project window (and the contents of Label Tracks or other tracks), with the Timeline aboveCloses all project windows and exits AudacityExports to an MP3 fileExports to a WAV fileExports to an OGG fileExports to an audio fileExports selected audio to a fileExports audio at one or more labels to file(s)Exports multiple audio files in one process, one file for each track if there are multiple audio tracks, or labels can be added which then define the length of each exported fileExports MIDI (note tracks) to a MIDI fileThe MenusFile-ExportMenu.png
Click for details
Click on the image to learn more


 


Advice For all types of audio export including Export Selected Audio and Export Multiple, tracks that are muted are not exported.

So if you play a preview before you export "what you hear is what you get" for the export.

Exports to specific audio file formats

If there are multiple tracks in your project, they will be automatically mixed in the exported data. For more information about mixing, see Mix and Render on the Tracks Menu.

Export as MP3

Exports the current Audacity project in compressed MP3 (lossy) audio file format.

See this page for more details

Export as WAV

Exports the current Audacity project in uncompressed WAV (lossless) audio file format. The default Encoding is 16-bit which you can change from the Encoding dropdown menu, if you do change it Audacity will remember and re-use your previous setting on next use.

See this page for more details.

Advice WAV files are limited to a maximum size of 4GB - see this page for details of how that relates to maximum times.

Export as Ogg Vorbis

Exports the current Audacity project in compressed Ogg Vorbis (lossy) audio file format.

See this page for more details.


Export Audio...  Ctrl + Shift + E

Exports the current Audacity project as an audio file format that can be read by other applications. As with the exports to specific audio file formats, if there are multiple tracks in your project, they will be automatically mixed in the exported data. For more information about mixing, see Mix and Render on this page.

You can choose the exported file format and settings from the Export Audio Dialog.

Muted tracks are not exported - so if you play a preview before you export "what you hear is what you get".


Export Selected Audio...

This is the same as Export Audio above, but it only exports the part of the project that is selected. For example, to save a small piece of a long track as a separate file, just select that audio as described in How do I select audio in one track? before using Export Selected Audio.

As with Export Audio muted tracks are not exported.


Export Labels...

If you have any Label Tracks, this command will export all their labels as a text file. The text in each label appears as one line in the exported file, prefaced by the start time and end time of the label (in seconds). If you have multiple label tracks, the labels in the uppermost label track appear first in the file.

To import the labels into an Audacity project later, use the File > Import... command.

Export Labels is commonly used in speech transcription or speech recognition research, after which the files can be manipulated in any application that accepts text files. Labels can also be modified after export for use as Cue Sheets for CD burning or as movie subtitles.

Extended format with frequency ranges

This is non-default and needs to be turned on in Import / Export Preferences in the Exported Label Style box if you wish or need to use this.

If a label is created from a point or region in a Spectrogram track where Spectral Selection is enabled (or if a label is otherwise created when a low frequency and high frequency value are already stored in the project), the exported labels file also contains the frequency range for that label.
Tip Export Labels cannot export selected label tracks or selections within label tracks.

To export individual label tracks the workaround is to:

  1. temporarily delete all but one label track and export that
  2. use Undo to restore the temporarily deleted label tracks
  3. repeat for each label track in turn


Export Multiple...  Ctrl + Shift + L

This allows you to do multiple exports from Audacity with one command. Export either multiple files based on the multiple tracks in the project, or based on the labels in a single audio track. A great timesaver for splitting up long recordings into separate CD tracks, or archiving multiple working tracks. See the Tutorial - Copying tapes, LPs or MiniDiscs to CD for an example of how this is used.

As with Export Audio muted tracks are not exported.


Export MIDI...

Export the currently selected Note Track as a MIDI or Allegro file (which is like a MIDI file except that the notes information is stored as plain text). You can choose in the Import / Export Preferences whether to export Allegro files with times and durations represented in seconds (default) or in beats. Some applications that can play MIDI files may not be able to play Allegro files.

Only one Note Track can be exported at a time. The entire Note Track will be exported regardless of any selection made in the track. If the Note Track has been time shifted to start at a point other than zero, empty MIDI bars will be added at the start.


<  Back to: File Menu