Sample workflow for exporting to iTunes

From Audacity Development Manual
Jump to: navigation, search

This tutorial outlines a set of example steps that can be used to get Audacity Projects (LP and tape transcriptions for example) into iTunes. The workflow concentrates on AAC music files because that is Apple's native, default, format. Some users may prefer to use uncompressed WAVs or AIFFs or compressed Apple Lossless formats for their music files in iTunes.

It is not the only way of working - there are many alternatives. Like any recipe it can be adapted to suit your personal needs. You can work in AIFF rather than WAV if required. Many Apple Mac users would probably prefer to work in AIFF.

See also Tutorial - Exporting to iTunes which has further useful information on this topic.

Workflow

  1. Export the WAV files
  2. Add the WAV files into iTunes
  3. Use iTunes to edit the metadata for the album name and artist
  4. Use iTunes to make AAC copies in the library from the WAV files
  5. Delete the WAV files from the library
  6. Edit the metadata tags of the tracks/album
  7. Fetch the album artwork
  8. Optionally make a CD - and create cover & playlist
  9. Backup your updated iTunes library
  10. Delete the Audacity project and exported WAV files to release hard disk space
  11. Optional direct AAC export from Audacity


Export the WAV files

Use Export Audio or Export Multiple to produce a WAV file or set of WAVs to any convenient location. With Audacity set to a project rate of 44100 Hz and 32-bit sample format (these are the default quality settings), exporting will by default produce 44.1kHz 16-bit PCM WAV files (or AIFF files on Mac). Audacity will down-sample from its 32-bit internal format to 16-bit, with shaped dither noise applied to cover any clicky noise that may result from the conversion to 16-bit. Advanced users can change the type of dither, or turn it off, in the Quality Preferences.

16-bit export will ensure the files are compatible with all versions of iTunes, They will also be compatible for conversion to AAC or other formats (or for CD burning) in iTunes. It is possible to export 32-bit PCM files too, by choosing "Other uncompressed files" in either export dialog, then clicking Options.... These files will theoretically be of marginally higher quality but twice the size of 16-bit files. Latest versions of iTunes will play them, but other players may not.

Add the WAV files into iTunes

Add the WAV files to the iTunes library (using the iTunes command File > Add File to Library or File > Add Folder to Library. Note that even if iTunes Import Preferences are set to Import Using AAC Settings ( Edit > Preferences > General > Import Settings ), no conversion takes place as this preference only applies to importing from CD.

Be aware that by default iTunes does not copy audio files into its own filespace, rather it makes a link to where you currently have the audio file stored.

To change this in iTunes go to Edit > Preferences > Advanced and mark the checkbox that says "Copy files to iTunes Media folder when adding to library". It is strongly recommended that you make this setting.

Use iTunes to edit the metadata for the album name and artist

Make sure that one of the columns you have showing in your iTunes library is Kind. The imported files will show as WAV and can be listed together by clicking on the "Kind" column header.

Select all the WAV files and use iTunes' metadata editor to enter the album name and the artist name so that you can easily find it later when editing the other metadata tags. You could alternatively set this metadata prior to Audacity Export using Audacity's metadata editor – some users report that it is easier to use iTunes rather than Audacity to manage the metadata.

Use iTunes to make AAC copies in the library from the WAV files

Provided that you did not already have other WAV files in your iTunes library, the WAV files you need should still be the only selected tunes at this stage, providing that you have done no further clicking. Make sure that you have your iTunes Import Settings set to AAC at your required bitrate. Convert them to AAC by using the iTunes command File > Convert . Note carefully that this makes a “copy” not a straight conversion – so at this stage your library will contain both the AAC and the WAV copies of the songs.

If you have plenty of room you may wish to keep the WAV files in your iTunes library to for their lossless quality and not convert them to AAC. In that case you should omit this conversion step and the next step which deletes the WAV files from your iTunes library. Yet another option is to set iTunes to convert to Apple Lossless which has about half the file size of WAV.

Or you may wish to use MP3 files in your iTunes library instead of AAC. In that case either export as MP3 from Audacity, to any convenient location, for import into iTunes or import WAVs and set iTunes to convert to MP3 rather than its default AAC. Note that for equivalent file size, AAC is generally reckoned to give better quality audio than MP3, but MP3 is a much safer choice if you want to send the file to someone else.

There are several advantages to using compressed format on iPods. The two main ones are that you can fit a lot more songs into the device (for 256 kbps files you can fit more than 8-9 times as many songs) and compressed files improve battery life (because disk reads are relatively heavy on battery power).

Delete the WAV files from the library

The WAV files should still remain as the selected tunes - just take extreme care at this stage (the AACs are created but selection is not forced by iTunes) So then just Delete the selected WAV files using the Delete key - and send the files to the wastebasket.

Note carefully that this workflow assumes that you have iTunes is set to copy files in, NOT to reference external files - so the WAVs that are deleted are iTunes’ copies of the original source WAVs. This is set in Edit > Preferences > Advanced with the Copy tunes into iTunes folder when adding to library checkbox.

Edit the metadata tags of the tracks/album

Edit the metadata tags for Song Name, track number and similar The album should be easy to locate in iTunes as you have already edited the Album tag in a previous workflow step above. You may wish to edit the song titles to remove the leading 01, 02 numbering series that was applied earlier to facilitate the correct ordering of the songs.

Fetch the album artwork

Find a copy of the album artwork - either directly via iTunes if the album is recognized by the Gracenote database CDDB (but note that Gracenote does not always carry the artwork), or by making a digital photo of the album cover, and add the artwork to the album. You may be able to find a copy of the album artwork on Amazon, Wikipedia or the artist's own website.

If you are using WAV files in your iTunes library then you cannot associate album artwork with these files.

Optionally make a CD – and create cover & playlist

You may wish to burn a CD from the WAV files. You can use iTunes to print CD covers with track-list and album cover; to do this you will need to create a temporary iTunes playlist for the album.

Backup your updated iTunes library

This is a critical step – you do not want to lose the valuable fruits of your labors, do you?

We would recommend maintaining two separate backup copies of your library on external disks.

Keep the WAV files that you exported from Audacity and back those up as well (two copies) on external disks.

Delete the Audacity project and exported WAV files to release hard disk space

After the backups are made you can then safely release space on your hard drive by deleting any Audacity project you created (delete both the .aup file and the _data folder with the same name) and deleting the originally exported WAV files.

Direct AAC export from Audacity

You may if you wish export to AAC compressed format (M4A files) from Audacity, to any convenient location, for direct import into iTunes. AAC export is one of the options available in the Export menus. To export to AAC, download and install the optional FFmpeg library. The export quality for M4A can be modified using the Options... button. The highest quality Audacity setting is roughly comparable to encoding to AAC in iTunes using VBR encoding at the highest bit rate preset.

Links

|< Tutorial - Copying tapes, LPs or MiniDiscs to CD

>  See also tutorial on: Sample workflow for LP digitization