Audacity 2.x AUP Projects

From Audacity Development Manual
Jump to: navigation, search
Audacity 2.x AUP projects can be successfully opened in Audacity 3.x, where they will be imported and converted to Audacity 3.x AUP3 project format.
  • It is important to note that a 2.x Audacity project is not a single audio file but a complex set of files managed by Audacity.
  • Audacity 2.x projects have a top-level AUP file and a related folder containing the sound files (the audio data).
  • The AUP is not a sound file, it is merely a list of instructions that tell Audacity how to construct the project from the sound files in the folder.

Contents

  1. Opening an Audacity 2.x Project in Audacity 3.0 or later
  2. Structure of an Audacity 2.x Project
  3. Deleting an Audacity 2.x project
  4. Moving or sending an Audacity 2.x project


Opening an Audacity 2.x Project in Audacity 3.0 or later

With the transition from Audacity 2.4.2 to Audacity 3.0.0 that Project file structure changed radically to having the entire project contained in a single unified file, see Managing Audacity Projects.

The good news is that Audacity can open AUP files created in older 2.x versions of Audacity , but saving the project will prevent it opening again in an earlier Audacity version.

  • Note that this will leave behind the old AUP file and its associated _data folder which you will probably want to delete to recover disk space.
  • Audacity version 3.x cannot open projects from Audacity 1.x, The workaround is to open the 1.x project in Audacity 2.x, save it as a 2.x project and then open the 2.x version of the project in Audacity 3.x.

When opening an AUP Audacity project in Audacity 3.x always use File > Open or File > Recent Files to open the "my-project.aup". Do not attempt to open, import or manipulate any individual AU block files.

Compressed and Lossless copies of 2.x projects

Early 2.x versions of Audacity enabled you to save a compressed copy of a project to save space. Later versions of 2.x additionally allowed you to save an uncompressed copy of a project as a backup. Audacity 3.x can successfully open both of those project formats.

Aliased audio files

Older versions of Audacity 2.x enabled you to work with external audio files attached to your project which were not actually copied into the project, these were known as "aliased files". This was done for speed reasons when computers were slower and to reduce disk space usage when disk space was smaller and more expensive.

If you have such projects they can still be successfully opened in Audacity 3.x provided you still have the aliased files present and in the locations that the old project expects to find them. Audacity 3.0.0 will copy these files into the project making the saved 3.x AUP3 project independent of the aliased files.

Older AUP project files

Audacity 3.x can even open AUP files from the 1.3 Beta series.

Tip Audacity version 3.x should be able to open projects from Audacity 1.1 onwards but not from 1.0

If it fails the workaround is to open the 1.x project in Audacity 2.x, save it as a 2.x project and then open the 2.x version of the project in Audacity 3.x.


Structure of an Audacity 2.x Project

Just to remind you, the structure of a 2.x Audacity project is:

  • An AUP project file - the name of the project followed by ".aup", for example "my-project.aup"
  • A _data folder with the same project name and in the same folder as the .aup file, for example "my-project_data"
  • Within that _data folder, a sub-folder structure with lots of little AU block files which are individual segments of the audio data.
  • The AUP project file describes how Audacity links these AU block files together to make up the clips and tracks in the project.
Tip Note that default behavior on Windows and Mac is to hide certain file extensions. If this applies, the .aup file will only appear as "my-project" in the computer.
  • On Windows, the .aup extension will be hidden if Audacity was installed from the .exe installer and "Hide file extensions for known file types" remains checked in Windows Explorer.
  • You can unhide extensions on Windows by following these instructions.
The three rules for keeping a 2.x Audacity Project happy:
  1. Never move, delete or rename any of the block files or folders inside the _data folder.
  2. Never rename the AUP file or the _data folder by hand.
    If you want to rename your project (for example, to save a snapshot at a particular point), use one of the File > Save Project > Save Lossless Copy of Project... or File > Save Project > Save Project As... commands.
  3. Always keep the AUP file and the _data folder together in the same directory (folder).


Deleting an Audacity 2.x project

There is no File > Delete Project command in Audacity; therefore to delete a project to free up disk space it is necessary to make the deletion manually. You will need to delete both the AUP file and its associated, identically named _data folder. '= Note that this will not remove the listing of your project under File > Recent Files.... After deleting the project you can choose the AUP entry for that project in the Recent Files list in order to remove the entry.


Moving, renaming or sending an Audacity 2.x AUP project

Moving or renaming Audacity projects can be tricky due to their complex structure as described above. Any project can be moved on the same computer, or renamed, by making a copy of the project with the File > Save Project > Save Project As... command.

Sending somebody just an AUP file does not send them an Audacity project - to do that you would need to send the _data folder containing the small AU files too.

Advice Never rename a 2.x AUP project by hand in any folder. Doing so will corrupt the project.

See also Sending your work to others.