File Menu: Import

From Audacity Development Manual
Jump to: navigation, search
Enables you to import audio files or label files into your project. Files in various audio formats can be imported into Audacity.
Import means bringing new content into an Audacity project by any means, such as File > Open, File > Import or dragging files into the project window. The content would typically be an audio file like WAV or MP3, but (using File > Import) could also be a label track, a MIDI file or Raw Data.

For audio files, the importer used depends on the currently selected file type in File > Open or File > Import > Audio... and on settings in Extended Import Preferences.
See Importing Audio for more information.

This menu has items to open, save, import and export files.The Edit Menu provides standard edit commands (Undo, Redo, Cut, Copy, Paste and Delete) plus many other commands specific to editing audio or labelsSelect Menu has commands that enable you make selections of tracks or parts of the tracks in your projectView Menu has commands that determine the amount of detail you see in all the tracks in the project window. It also lets you show or hide Toolbars and some additional windows such as Undo HistoryTransport Menu commands let you play or stop, loop play, scrub play or record (including timed and sound activated recordings)Tracks Menu provides commands for creating and removing tracks, applying operations to selected tracks such as mixing, resampling or converting from stereo to mono, and lets you add or edit labelsGenerate Menu lets you create audio containing tones, noise or silenceAudacity includes many built-in effects and also lets you use a wide range of plug-in effectsThe Analyze Menu contains tools for finding out about the characteristics of your audio, or labeling key featureThe Tools Menu contains customisable toolsThe Extra menu provides access to additional Commands that are not available in the normal default Audacity menusThe Help Menu lets you find out more about the Audacity application and how to use it.  It also includes some diagnostic tools.Creates a new empty project window, to start working on new or imported tracksPresents you with a file selection dialog box to open filesLists the full path to the twelve most recently saved or opened projects or most recently imported audio filesCloses the current project window, prompting you to save your work if you have not savedVarious ways to save a projectFor exporting audio filesFor importing audio files or label files into your projectOpens the standard Page Setup dialog box prior to printingPrints all the waveforms in the current project window (and the contents of Label Tracks or other tracks), with the Timeline aboveCloses all project windows and exits AudacitySimilar to 'Open', except that the file is added as a new track to your existing projectLaunches a file selection window where you can choose to import a single text file into the project containing point or region labelsImports a MIDI (MIDI or MID extension) or Allegro (GRO) file to a Note Track where simple cut-and-paste edits can be performedAttempts to import an uncompressed audio file that might be "raw" data without any headers to define its format, might have incorrect headers or be otherwise partially corrupted, or might be in a format that Audacity is unable to recognizeThe MenusFile-ImportMenu.png
Click for details
Click on the image to learn more


 


Audio...  Ctrl +Shift + I

Launches a file selection window where you can choose to import one or more audio files into the current Audacity project. The file(s) will always be added as a new track to the project. This lets you mix two or more files together.

See Importing Audio for more information.


Labels...

Launches a file selection window where you can choose to import a single text file into the project containing point or region labels. For more information about the syntax for labels files, see Importing and Exporting Labels.


MIDI...

Imports a MIDI (MIDI or MID extension) or Allegro (GRO) file to a Note Track where the Note track can be played.

This should just work on Windows but for playback on Mac and Linux additional software may be required, see this section on the Playing and Recording page.

Simple cut-and-paste edits can also be performed. The result can be exported with the File > Export > Export MIDI command.


Raw Data...

ImportRawData.PNG

Attempts to import an uncompressed audio file that might be "raw" data without any headers to define its format, might have incorrect headers or be otherwise partially corrupted, or might be in a format that Audacity is unable to recognize. Raw data in textual format cannot be imported.

First, select the file in question in the "Select any uncompressed audio file" dialog.

Then use the Detect button to let Audacity make a guess as to what kind of data your file is. If you know what kind of data you're dealing with, or if Audacity misidentified the format, you can set the following parameters yourself as well:

  • Encoding (PCM, ADPCM, float...)
  • Byte order (this is almost always Little-endian if the file was created on Windows)
  • Number of channels (expected to be found in the file and created as a result)
  • Start offset in bytes
  • Percentage amount of the file to import
  • Sample rate to be applied to the import (currently, rates between 100 Hz and 384,000 Hz are supported)


<  Back to: File Menu