Help Menu: Diagnostics

From Audacity Development Manual
Jump to: navigation, search
Audacity's diagnostic tool-box.
The Help Menu lets you find out more about the Audacity application and how to use it.  It also includes some diagnostic tools.A brief version of help with some of the most essential informationOpens the manual in the default browserA set of diagnostic toolsChecks online to see if this is the latest version of AudacityBrings a dialog with information about Audacity, such as who wrote it, what features are enabled and the GNU GPL v2 licenseShows technical information about your detected audio device(s)Shows technical information about your detected MIDI device(s)Launches the "Audacity Log" window, the log is largely a debugging aid, having timestamps for each entrySelecting this will generate a Debug report which could be useful in aiding the developers to identify bugs in Audacity or in third-party plug-insLists any WAV or AIFF audio files that your project depends on, and allows you to copy these files into the projectThe MenusHelp-DiagnosticsMenu.png
Click for details
Click on the image to learn more


 


Audio Device Info...  

Shows technical information about your detected audio device(s), including their supported sample rates. This item is grayed out if you are playing, recording or paused. Press OK to save the information as a text file, or Cancel to return to the main project window.

MIDI Device Info...  

Shows technical information about your detected MIDI device(s). This item is grayed out if you are playing, recording or paused. Press OK to save the information as a text file, or Cancel to return to the main project window.

Show Log...  

Launches the "Audacity Log" window, which can be kept open while Audacity is used normally. The log is largely a debugging aid, having timestamps for each entry. The Audacity version number is always the first entry at the top. Other log entries are added underneath the version number as needed.

  • If you use the optional FFmpeg library, the log shows entries for the steps to load the individual FFmpeg components and whether FFmpeg load succeeded.
  • If you import an audio file, the log shows the imported file's name and extension, which import libraries attempted to import the file and whether the file import succeeded.
  • If Audacity crashes and the Automatic Crash Recovery dialog appears on restarting Audacity, or if Audacity encounters a problem when opening an AUP project file, the log may contain additional useful error details.

Buttons

  • Save... : Opens a standard file save dialog where you can save the current contents of the log to a text file.
  • Clear Clears the current contents of the log, then inserts the Audacity version number at the top followed by a "Log Cleared." message underneath, both with current timestamps.
  • Close Closes the log, preserving its current content for the remainder of the Audacity session.
Warning icon On quitting Audacity the log content is discarded. If you need to save the log contents, do so using the Save... button (or generate a Debug Report as below) before quitting.

Generate Support Data...  

Selecting this will generate a Debug report which could be useful in aiding the developers to identify bugs in Audacity or in third-party plug-ins. A ZIP file will be created for easy emailing but the files included in the ZIP are also saved separately.

Debug report.png

By default, all items are selected for inclusion in the report. If you wish to exclude any item, select and uncheck it. You can also view or open the selected item before creating the report. The View... button opens the selected item in an Audacity window. The Open... button opens the selected item in your default application for that document type.

When you click OK, Audacity will confirm generation of the report and the exact name and folder location of the Debug report ZIP file. You can copy this name and location to the system clipboard. The folder location will be:

  • Windows: C:\\Users\\<your username>\\AppData\\Local\\Temp\\
  • Mac: A subfolder in /var/folders/ - an example subfolder might look something like /var/folders/c0/8p18hd453p3_433cf9_595b40000gn/T/.
  • GNU/Linux: /tmp/.

The name of the folder where the separate files are saved specifies the date and time of the report (on Mac and Linux the ZIP's file name also specifies the report's date and time). Below is an example image of the confirmation of generation dialog on Windows:

Debug report location.png

You can then attach the ZIP file to any bug report or issue that you report. Please submit your report to our feedback address or to the Audacity Forum.

Warning icon If the dialog appears of its own accord this will almost certainly be because Audacity has crashed. Audacity will exit after you select OK or Cancel in the dialog and will attempt to recover your project after you restart Audacity.

Check Dependencies...  

Lists any WAV or AIFF audio files that your project (created in earlier versions of Audacity) depends on, and allows you to copy these files into the project.

In earlier versions of Audacity (2.3.2 and previous) it was possible to reference external uncompressed audio files rather than importing and reading them into the Audacity project. This was quicker and saved space but was rather dangerous, as the project could become unusable if the files were moved or renamed.

Accordingly we removed this feature from Audacity and now all imported audio files are fully read into the Audacity project, making the project self-contained.

However there will still be some projects created with earlier versions of Audacity that still depend on external audio files. In order for these projects to continue to work On-Demand Loading has been retained for such projects.

Warning icon If you have a project that depends on external audio files, do NOT rename, move or delete those files, otherwise your project will be missing audio.

You can copy in the audio to the project at any time, making the project fully self-contained, using the File > Diagnostics > Check Dependencies... command.

<  Back to: Help Menu