Tools Menu: Apply Macro

From Audacity Development Manual
Jump to: navigation, search
Tools Menu provides miscellaneous commands that:
  • Act on the project.
  • Don't fit into the categories Effects, Generators or Analyzers.
The Tools Menu contains customisable toolsThe Extra menu provides access to additional Commands that are not available in the normal default Audacity menusThe Help Menu lets you find out more about the Audacity application and how to use it.  It also includes some diagnostic tools.Enable or disable particular Effects, Generators and AnalyzersCreates a new Macro or edits an existing MacroDisplays a menu with list of all your MacrosReset most settings back to the default valuesA tool, mainly used in documentation, to capture screenshots of AudacityA tool for measuring the performance of one part of AudacityBrings up a dialog where you can enter Nyquist commandsA  Nyquist plug-in that simplifies the installation of other Nyquist plug-insPlaces labels in a long track so as to divide it into smaller, equally sized  segmentsReads the values of successive samples from the selected audio and prints this data to a plain text, CSV or HTML fileReads numeric values from a plain ASCII text file and creates a PCM sample for each numeric value readDisplays a menu with list of all your Macros which can be applied to the current project or to audio files.Fades in the first second and fades out the last second of a trackConverts MP3The MenusTools-Apply MacroMenu.png
Click for details
Click on the image to learn more


 


Palette...

Clicking on this will show the Macro Palette, a dialog with a list of all your Macros.

You can select any of the listed Macros and apply them either to the current project or to audio files.

The list of names may vary from what is shown here, depending on what macros you have defined.

MacrosPalette.png


<Macro Name>

If you have created your own custom Macros these Macros and those pre-shipped with Audacity will be listed in the dropdown menu.

Selecting any of these Macros by clicking on it will cause that Macro to be applied to the current project.