Analyze Menu

From Audacity Development Manual
Jump to: navigation, search
The Analyze Menu contains tools for finding out about the characteristics of your audio, or labeling key features. Plug-ins that accept audio input but produce no audio output will be placed in the Analyze menu, with the analysis results being provided by labels (or in some optional LADSPA plug-ins by an "Effect Output" section in the plug-in itself).

Although by default, no keyboard shortcuts are provided for most of the analysis tools, it is possible to set up your own shortcut for any Analyze command. For instructions on how to do this please see Keyboard Preferences.

The Analyze Menu contains tools for finding out about the characteristics of your audio, or labeling key featureThe Tools Menu contains customisable toolsThe Extra menu provides access to additional Commands that are not available in the normal default Audacity menusThe Help Menu lets you find out more about the Audacity application and how to use it.  It also includes some diagnostic tools.Enable or disable particular Effects, Generators and AnalyzersAnalyzes a single mono or stereo speech track to determine the average RMS difference in volume (contrast) between foreground speech and background music, audience noise or similarTakes the selected audio (which is a set of sound pressure values at points in time) and converts it to a graph of frequencies against amplitudesDisplays runs of clipped samples in a Label Track, as a screen-reader accessible alternative to {{menu|View > Show Clipping}}Attempts to place labels at beats which are much louder than the surrounding audioDivides up a track by placing point labels inside areas of silenceDivides up a track by placing region labels for areas of sound that are separated by silenceThe MenusAnalyzeMenu.png
Click for details
Click on the image to learn more


 



  • Many of the analysis tools shipped in Audacity are Nyquist plug-ins which can be edited in any text editor. See Nyquist Plug-ins Reference on our Wiki for more details about the Nyquist format. You can download additional Nyquist analysis plug-ins. The built-in analyzers are LADSPA effects. Some additional LADSPA analysis plug-ins for Linux can be downloaded from http://www.ladspa.org/.
  • The description page for each shipped analysis effect (accessed by the links below) shows an image of the interface and its default settings.

Audacity's Analysis Tools

Add / Remove Plug-ins...

Selecting this option from the Analyze Menu (or the Effect Menu or Generate Menu) takes you to a dialog which enables you to load and unload Analyzers (and Effects and Generators) from Audacity. This enables you to customize your Analyze Menu making it shorter or longer as required. For details see Plug-in Manager: Effects, Generators and Analyzers.

Additional plug-ins can also be loaded into Audacity. For details see the following FAQs: Windows, Mac and Linux

See also this list of available Nyquist analyzer plug-ins on the Audacity Wiki, that you can easily download and add to Audacity.


Backing up or transferring settings

To see how to backup your settings, last used and any user presets you have saved using the Manage button in each analyzer's dialog, see this page.


Built-in LADSPA analysis tools

Contrast...  Ctrl + Shift + T   Extra

Analyzes a selected, single non-stereo audio track to determine the average rms difference in volume (contrast) between foreground (the speech) and background (music, audience noise or similar). The purpose is to determine if the speech will be intelligible to the hard of hearing.

Plot Spectrum...

Takes the selected audio (which is a set of sound pressure values at points in time) and converts it to a graph of frequencies (the horizontal scale in Hz) against amplitudes (the vertical scale in dB).

Find Clipping...

Displays runs of clipped samples in a Label Track, as a screen-reader accessible alternative to View > Show Clipping. A run must include at least one clipped sample, but may include unclipped samples too.

Nyquist Plug-in analysis tools shipped with Audacity

Beat Finder...

Attempts to place labels at beats which are much louder than the surrounding audio. It's a fairly rough and ready tool, and will not necessarily work well on a typical modern pop music track with compressed dynamic range.

Measure RMS

A simple analyzer to measure the RMS (Root Mean Square) levels in a track.

Measure RMS is not enabled by default. To enable it, use Analyze > Add / Remove Plug-ins...   to open the Plug-in Manager dialog. There you will find the file listed as "rms", but it will enable as Measure RMS.

Silence Finder...

Divides a track up by placing point labels inside areas of silence. Use this if you just want to split the recording into tracks at a specific point without removing the silences between them.

Sound Finder...

Divides a track up by placing region labels for areas of sound that are separated by silence. Use this to make the labels show the exact region of each track to be exported. This lets you remove some or all of the silence between the tracks.

Bulb icon The two related "Silence Finder" and "Sound Finder" tools are very useful to label the different songs or sections in a long recording, such as the tracks from an LP or cassette.


Vamp Analysis Plug-ins

You can also add some additional analysis tools in the Vamp plug-in format for viewing and analysing the descriptive contents of music audio files. Typical things that a Vamp plug-in might calculate include the locations of moments such as note onset times and power or fundamental frequency data. Plug-ins that produce graphs or other visuals will not work in Audacity, only plug-ins that are suitable for writing to labels.

To add a new Vamp analysis tool, add the plug-in's DLL, DYLIB or SO file (and any supplied category (CAT) or RDF (TTL or N3) files) to one of the paths listed in the green box below.

To run a Vamp plug-in, select the audio and run the plug-in from the menu. An annotated label track appears showing the result.

Warning icon Currently Audacity cannot load Vamp plug-ins from the Audacity "Plug-Ins" folder.

Vamp plug-ins are loaded from the following standard directories each time you launch Audacity:

  • On all platforms: any directories listed in the VAMP_PATH environment variable
  • additionally on Windows:
    • C:\\Program Files\\Vamp Plugins on Windows 32-bit or C:\\Program Files (x86)\\Vamp Plugins on Windows 64-bit.
  • additionally on macOS / OS X:
    • ~/Library/Audio/Plug-Ins/Vamp (user plug-ins)
    • /Library/Audio/Plug-Ins/Vamp (system-wide plug-ins)
Bulb icon On Mac the folders that you need may be "hidden". To access them in Finder use  Go > Go To Folder > ~/Library ...    or   Go > Go To Folder > /Library ...

The Go is in the menu bar at the top of the desktop when Finder is active.

  • additionally on Linux/Unix:
    • $HOME/vamp
    • $HOME/.vamp
    • /usr/local/lib/vamp (user plug-ins)
    • /usr/lib/vamp (system-wide plug-ins).