Select Menu

From Audacity Development Manual
Jump to: navigation, search
The Select Menu provides a set of commands for defining selection regions, prior to acting on those regions with edits, effects and exports.
  • You also can position the editing cursor.
  • You can also select clips and navigate between clips.
Select Menu has commands that enable you make selections of tracks or parts of the tracks in your projectView Menu has commands that determine the amount of detail you see in all the tracks in the project window. It also lets you show or hide Toolbars and some additional windows such as Undo HistoryTransport Menu commands let you play or stop, loop play, scrub play or record (including timed and sound activated recordings)Tracks Menu provides commands for creating and removing tracks, applying operations to selected tracks such as mixing, resampling or converting from stereo to mono, and lets you add or edit labelsGenerate Menu lets you create audio containing tones, noise or silenceAudacity includes many built-in effects and also lets you use a wide range of plug-in effectsThe Analyze Menu contains tools for finding out about the characteristics of your audio, or labeling key featureThe Tools Menu contains customisable toolsThe Extra menu provides access to additional Commands that are not available in the normal default Audacity menusThe Help Menu lets you find out more about the Audacity application and how to use it.  It also includes some diagnostic tools.Selects all of the audio in all of the tracksDeselects all of the audio in all of the tracksTracksFor modifying, saving and restoring a selectionFor making a selection of a frequency rangeFor modifying a selection, taking account of clipsSelects from the position of the cursor to the previously stored cursor positionStores the current cursor position for use in a later selectionMoves the edges of a selection region (or the cursor position) slightly so they are at a rising zero crossing pointThe MenusSelectMenu.png
Click for details
Click on the image to learn more


 



Mac users: Ctrl = . So, for example, Ctrl + A = ⌘ + A

All  Ctrl + A

Selects all of the audio in all of the tracks.

None  Ctrl + Shift + A   Extra

Deselects all of the audio in all of the tracks.

Tracks

The Tracks submenu has commands to extend the current selection up and/or down into all tracks, or into all Sync-Locked tracks in the project.

Region

The Region submenu has commands for defining selection regions and lets you store and retrieve the position of the editing cursor or selection region.

Spectral

The Spectral submenu has contains to enable you to make Spectral selection which can be used to make selections that include a frequency range as well as a time range on tracks in Spectrogram view. Spectral selection is used with special spectral edit effects to make changes to the frequency content of the selected audio.

Clip Boundaries

The Clip Boundaries submenu lets you select between the editing cursor and clip boundaries or to navigate though clips, selecting all of the current clip.

Cursor to Stored Cursor Position  

When playing or recording (or paused):, selection is made from the the position of the Playback cursor PlaybackCursor.png or Recording cursor RecordingCursor.png to the position previously saved by the Select > Store Cursor Position command. For easier use without having to Pause, you may want to add a shortcut for "Cursor to Stored Cursor Position".

When there is no active audio: selects from the current position of the editing cursor (or from the left edge of the current selection region) to the stored position.

Example: Suppose you had paused playback (or stopped playback and set cursor) at the starting point of an intended selection and had stored that position. You could then start playback further along from the stored position in order to find the ending point of the intended selection. When you hear that ending, use "Cursor to Stored Cursor Position" to select from the stored position to the position of the playback cursor. You can then stop playback and the selection region will be retained.

An alternative procedure if you want to store many positions is to add a label when required at the editing cursor or playback/recording cursor.


Store Cursor Position  

Stores a cursor position as defined below, which can then be used with the Select > Cursor to Stored Cursor Position command to create or modify a selection region.

  • If audio is not actively playing, recording or paused: the stored cursor position is the position of the editing cursor or of the left edge of the selection region.
  • If audio is active: the stored cursor position is the position of the Playback cursor PlaybackCursor.png or Recording cursor RecordingCursor.png at the time you issue the command to store. For easier use without having to Pause, you may want to add a shortcut for "Store Cursor Position".

If you want to store the position of the editing cursor (or both boundaries of a selection) while audio is active, use the Select > Region > Store Selection command.

Advice There is no visual cue marker to remind you what position you saved, you will need to remember it.

At Zero Crossings  Z

At Zero Crossings helps to avoid clicks at edit points when making cuts and joins by moving the edges of a selection region (or the cursor position) very slightly so they are at a rising zero crossing point.

Advice This feature does not necessarily find the nearest zero crossing to the current position. It aims to find the crossing where the average amplitude of samples in the vicinity is lowest.