Sound Finder

From Audacity Development Manual
Jump to: navigation, search


Advice This effect has been superseded by the much-improved Label Sounds.

You can still continue to use this analyzer if it is present in your Audacity app as a result of an earlier Audacity version download.

Sound Finder and the related Silence Finder are tools which can useful to label the different songs or sections in a long recording, such as the tracks from an LP or cassette.

After typing the name of the track or section in each label, File > Export > Export Multiple... will export audio files in one process corresponding to each label's audio. See Splitting a recording into separate tracks.

Tip If you already have a label track and that is included in the selection that you make for the analysis then these labels will be added to your selected label track - possibly causing confusion with your existing labels.
  • Workaround: Ensure you just select audio track(s) and include no label track in the selection for the analysis. Audacity will then create a new label track for the analysis output named "Label Track" - you may wish to rename that so that you remember what the labels in the analysis track refer to.


Accessed by: Analyze > Sound Finder...
Sound Finder.png

Sound Finder divides up a selection by placing region labels for areas of sound that are separated by silence. Use this to make the labels show the exact region of each track to be exported. This lets you remove some or all of the silence between the tracks.

If any album tracks have more than one label, increase the silence level and duration. If any labels extend into other album tracks, reduce the silence level and duration.


Buttons

Clicking on the command buttons give the following results:

  • Manage gives a dropdown menu enabling you to manage presets for the tool and to see some detail about the tool. For details see Manage presets
  • Debug applies the effect to the selected audio with the current effect settings, but unlike OK the effect runs in debug mode. This is primarily of use when writing or editing Nyquist plug-ins.
    • In addition to the normal plug-in behavior, a "debug window" opens to display error messages, normally the debug window will be empty
  • OK applies the effect to the selected audio with the current effect settings and closes the dialog
  • Cancel aborts the effect and leaves the audio unchanged, closing the dialog
  • Help Button brings you to the appropriate page in the Manual, this page


Examples

See Silence Finder and Sound Finder for examples comparing and contrasting the usage of Silence Finder and Sound Finder.

Links

|< Index of Effects, Generators and Analyzers

|< Analyze Menu

> Silence Finder