Tools Menu

From Audacity Development Manual
Jump to: navigation, search
Tools Menu provides miscellaneous commands that:
  • Act on the project.
  • Don't fit into the categories Effects, Generators or Analyzers.
The Tools Menu contains customisable toolsThe Extra menu provides access to additional Commands that are not available in the normal default Audacity menusThe Help Menu lets you find out more about the Audacity application and how to use it.  It also includes some diagnostic tools.Enable or disable particular Effects, Generators and AnalyzersCreates a new Macro or edits an existing MacroDisplays a menu with list of all your MacrosReset most settings back to the default valuesA tool, mainly used in documentation, to capture screenshots of AudacityA tool for measuring the performance of one part of AudacityBrings up a dialog where you can enter Nyquist commandsA  Nyquist plug-in that simplifies the installation of other Nyquist plug-insPlaces labels in a long track so as to divide it into smaller, equally sized  segmentsReads the values of successive samples from the selected audio and prints this data to a plain text, CSV or HTML fileReads numeric values from a plain ASCII text file and creates a PCM sample for each numeric value readThe MenusToolsMenu.png
Click for details
Click on the image to learn more


 



Add / Remove Plug-ins...

Selecting this option from the Tools Menu (or the Effect, Generate or Analyze menus) takes you to a dialog which enables you to load and unload Tools (and Effects and Generators and Analyzers) from Audacity. This enables you to customize your Tools Menu making it shorter or longer as required. For details see Add / Remove Effects, Generators and Analyzers.

By default all the Built-in Tools are loaded in Audacity.

Additional plug-ins can also be loaded into Audacity. For details see the following FAQs for: Windows, Mac and Linux

See also this list of available Nyquist tool plug-ins on the Audacity Wiki, that you can easily download and add to Audacity.


Macros...  

Shows the full-function Manage Macros dialog, from which you can edit macros, and apply them.

Macros (Compact Dialog)  

Use the Shrink button in the full Manage Macros dialog to get the reduced apply-only dialog.

This is a smaller version dialog which only has Apply Macro functionality and no Macro editing available. You can get back to the full Manage Macros version by clicking the Expand button.

This reduced version is useful for presets. It stays open after applying a macro, so it is a palette of custom functions, and you can pick another and apply that.


Apply Macro

Clicking on this will show a menu with list of all your Macros. Selecting any of these Macros by clicking on it will cause that Macro to be applied to the current project.

The Apply Macro command is a good way of having a palette of favorite presets for the effects you regularly use.


Reset Configuration

This resets your Audacity configuration, preferences, export settings and toolbars, to default settings.

Warning icon Be aware that this command acts immediately with no dialog and no choice of actions or chance to abort and Undo is not available for this command.

User presets in Effects, Generators and Analyzers are left untouched, as are any Macros you may have created.


Screenshot...  

Displays the "Screen Capture Frame" dialog. This tool lets you capture all or part of your project window to an image file in PNG format. Click the Choose... button to pick the location where you want to save the screenshot. Then click the button corresponding to the part of the project window you want to capture. Most of these buttons are self-explanatory.

Screenshot tools can be handy for capturing:

  • Tracks with their waveform or spectrogram (use any of the three ... Tracks buttons)
  • Plots of amplitude against frequency for a selected region (use any of the Capture Window buttons to capture the Frequency Analysis window on its own).

See Screenshot page for more details.


Run Benchmark...  

Performs a mock editing routine to test how fast Audacity runs on your machine, expressed in terms of the estimated number of simultaneous tracks that could be played at once in a 44100 Hz, 16 bits per sample project.

If the sample rate of the tracks differs from the Project Rate, causing real-time sample rate conversion, the number of tracks you can play may be lower than the Benchmark result. Using stereo or mono tracks, or using the default 32-bit sample format instead of 16-bit should not significantly change the number of tracks you can play.


Nyquist Prompt...

Enables you to run and debug code snippets for your own plug-ins created using the Nyquist programming language. See Nyquist Plug-ins Reference - Audacity Wiki for more information about writing Nyquist code.


Nyquist Plug-in Installer...

The Nyquist Plug-in Installer is itself a Nyquist plug-in that simplifies the installation of other Nyquist plug-ins.

All Nyquist plug-ins are plain text files that have the filename extension '.NY'. This plug-in installer provides a file browser for selecting the plug-in '.NY' file, and then copies the file to the correct location. Once the plug-in has been installed, it may be enabled in the 'Plug-in Manager.'


Regular Interval Labels...

Places point labels in a label track so as to divide the associated audio into smaller, equally-sized segments. This can be useful for distributing a large file on the internet or ensuring that all exported files are the same size.

You can either choose the number of labels to be created or the interval between them. Each label produced can contain specified label text and the labels can be given sequential numbers before or after the text.


Sample Data Export...

Reads the values of successive samples from the selected audio and prints this data to a plain text, CSV or HTML file. Further information may be added as a "header" at the top of the file.


Sample Data Import...

Reads numeric values from a plain ASCII text file and creates a PCM sample for each numeric value read. The values are read as 32-bit floating point numbers, where a range of +/- 1.0 represents 0 dB (full scale).

  • The file MUST be plain ASCII text, and values should be separated by spaces, tabs or line-breaks.
  • The file name must have a '.txt' file extension.