File Menu

From Audacity Development Manual
(Redirected from File Menu: Recent Files)
Jump to: navigation, search
The File Menu provides commands for creating, opening and saving Audacity projects, importing and exporting audio files.
This menu has items to open, save, import and export files.The Edit Menu provides standard edit commands (Undo, Redo, Cut, Copy, Paste and Delete) plus many other commands specific to editing audio or labelsSelect Menu has commands that enable you make selections of tracks or parts of the tracks in your projectView Menu has commands that determine the amount of detail you see in all the tracks in the project window. It also lets you show or hide Toolbars and some additional windows such as Undo HistoryTransport Menu commands let you play or stop, loop play, scrub play or record (including timed and sound activated recordings)Tracks Menu provides commands for creating and removing tracks, applying operations to selected tracks such as mixing, resampling or converting from stereo to mono, and lets you add or edit labelsGenerate Menu lets you create audio containing tones, noise or silenceAudacity includes many built-in effects and also lets you use a wide range of plug-in effectsThe Analyze Menu contains tools for finding out about the characteristics of your audio, or labeling key featureThe Tools Menu contains customisable toolsThe Extra menu provides access to additional Commands that are not available in the normal default Audacity menusThe Help Menu lets you find out more about the Audacity application and how to use it.  It also includes some diagnostic tools.Creates a new empty project window, to start working on new or imported tracksPresents you with a file selection dialog box to open filesLists the full path to the twelve most recently saved or opened projects or most recently imported audio filesCloses the current project window, prompting you to save your work if you have not savedVarious ways to save a projectFor exporting audio filesFor importing audio files or label files into your projectOpens the standard Page Setup dialog box prior to printingPrints all the waveforms in the current project window (and the contents of Label Tracks or other tracks), with the Timeline aboveCloses all project windows and exits AudacityThe MenusFileMenu.png
Click for details
Click on the image to learn more


 



New  Ctrl + N

Creates a new and empty project window to start working on new or imported Tracks. This new work environment can then be saved as an Audacity Project File (.AUP) for easy and full retrieval of its contents via the Save Project or Save Project As... File menu functions.

Open...  Ctrl + O

Launches a file selection window where you can Open one or more Audacity Project files.

In earlier versions of Audacity it was possible to create projects dependent upon external audio files (for speed and to save space) - but this was rather dangerous and has been withdrawn from Audacity. However, previous projects that use such external audio files are still supported with On-Demand Loading.

Import using Open

You can also use the Open command to Import one or more audio files or lists of files (.LOF).

Warning icon Note carefully that this does not actually "open" your audio file(s) for editing, rather it copies it into Audacity in Audacity's internal project format where it can be worked on.

If an empty project window exists, that window will be used for the first project or imported file. Any subsequent opened projects or audio files will create new project windows.

Bulb icon If instead you want to add the content of an audio file into a project that already contains one or more audio tracks (for example, to mix two audio files together), use File > Import > Audio... instead.

Missing or orphan block files

Occasionally when a project is opened Audacity will find that there may be some missing data (block files) or some additional extraneous data not needed for the project.

This is normally caused by a system or application crash but sometimes can be down to (as yet undiscovered bugs).

If this happens warning messages will be displayed:

The above links explain the possible remedial actions you can take in these circumstances.


Recent Files ("Open Recent" on Mac)

Lists the full path to the twelve most recently saved or opened projects or most recently imported audio files. The oldest item at the bottom is removed when a new item is added to the top. When you delete an Audacity project or audio file it will remain in the list, but will be removed from the list if you select it.

  • To clear the entire list, choose "Clear" underneath the last item in the list.
  • To manually remove an individual item from the list, exit Audacity, open audacity.cfg in a text editor and delete the unwanted item below the [Recent Files] line. Take care not to delete the [Recent Files] line itself.


Close  Ctrl + W

Closes the current project window, prompting you to save your work if you have not already saved.


Save Project  Ctrl + S

The Save Project submenu enables you to Save your project in full uncompressed mode (or compressed which saves space). You can also store projects as backup safety copies at stages throughout your project. Note that Audacity projects only work in Audacity, they cannot be read and played by other applications.

The current zoom level is saved in the project when you save the project. When a saved project is opened, it should automatically be zoomed to the same place and zoom level as when you saved it.

Bulb icon It is not advisable to save your project to be on an external USB stick/disk as it is unlikely to be fast enough for satisfactory recording.


Export

The Export submenu enables you to Export audio from Audacity into audio file formats that can be read and played by other applications. Additionally you can export label files or MIDI or save a compressed copy of your project in a set of Ogg Vorbis formatted files.


Import

The Import submenu enables you to import audio files or label files into your project. Files in various audio formats can be imported into Audacity.

For details of the available imports see this page.


Page Setup...

Opens the standard Page Setup dialog box prior to printing.


Print...

Prints all the waveforms in the current project window (and the contents of Label Tracks or other tracks), with the Timeline above. Everything is printed to one page.

To include the Track Control Panel, or to print other parts of the interface, you could use use the Tools > Screenshot function to capture a screen print to a file, then use the print function of your favorite image editor.


Exit  Ctrl + Q

Closes all project windows and exits Audacity. If there are any unsaved changes to your project, Audacity will ask if you want to save them. Note that it is not necessary for you to save changes if you've already exported your mix as a WAV or MP3 and you are now happy with it. But if you are working on a mix and plan to continue later where you left off, saving an Audacity Project will let you restore everything, exactly as you left it.

On a Mac, the Exit command is not in the File Menu. Instead, use "Quit" under the Audacity menu.