FAQ:Opening and Saving Files

From Audacity Development Manual
Jump to: navigation, search

>  Forward To: FAQ:MP3 export problems

<  Back to: FAQ:Playback

|< Index of Frequently Asked Questions


How do I save my audio for use in other applications? Does saving a project (AUP3 file) do that?

An AUP3 file can only be saved and used in Audacity. It lets you resume working on that audio in Audacity at a later time if you need to.

Whenever you want to use your audio in other applications, choose the File > Export sub-commands to export a standard audio format like WAV, AIFF or MP3.

  • WAV and AIFF are lossless files which you can also burn to an audio CD or use again for further editing.
  • MP3 and M4A/MP4 are lossy smaller files that are useful for portable music players or sending over the Internet.

Before saving the exported file, click Options... in the Export Audio Dialog to see if there are choices for the quality and size of the file.

Tip If you have already saved an AUP file but now want to export an audio file, reopen that AUP using File > Open.... If you saved the project recently, you can also find the project in the File > Recent Files menu.

To learn more about working with AUP files, please see Audacity Projects.


back to top

Audacity crashed, or I no longer have the AUP3 project file! Can I recover the data?

In the event of a crash while Audacity has unsaved data (such as a recording that has not yet been saved as a project, or an existing project with unsaved changes), Audacity will attempt to recover that data on next launch of Audacity. See Automatic Crash Recovery for full details.

If the computer itself crashed, see Why does the computer reboot or show a blue screen message when I play or record in Audacity?.

If Audacity crashed and you saw the Debug report "Audacity" dialog, please write to us attaching the zipped support data so we can investigate, telling us what you did in Audacity just before the crash.

back to top

Can Audacity import or export formats like WMA, AC3 or Apple Music/iTunes files (M4A/MP4)?

Audacity as shipped can import or export the following audio formats:


You can install the optional FFmpeg library to import and export a much larger range of audio formats including AC3, AMR(NB), M4A, MP4 and WMA (on Mac only, Audacity can import unprotected M4A, MP4 and MOV files without FFmpeg). Audio files that are DRM-protected to work only in particular software cannot be imported. FFmpeg will also import audio from most video files or DVDs that are not DRM-protected.

You can export to Apple Music/iTunes by exporting to any location on your computer then add the file to the Apple Music/iTunes library.

See Importing Audio and the Export Audio Dialog for more help with importing and exporting.

If an audio file you want to import is DRM-protected (for example, an older iTunes M4P file), first burn it to an audio CD in the application that is licensed to play it. Then rip the CD track to WAV or AIFF. You can also record the file as it plays on the computer if your sound device supports this, though this may result in slight loss of quality.
Tip Audacity does not natively support Opus. If FFmpeg is installed, Audacity will attempt to use FFmpeg for importing Opus files.

See also:

back to top


How can I export to formats not listed in the Export Audio Dialog?

If you install the optional FFmpeg library you can use the (FFmpeg) choices in the Export Audio Dialog to export M4A (AAC), AC3, AMR (narrow band) and WMA. If you do not see a choice for one of those specific FFmpeg formats, then the build of FFmpeg you are linking to was not compiled to support encoding in that format.

The most flexible method to export to more formats is to choose (external program) in the Export Audio Dialog which opens the dialog for Audacity's command-line encoder. Point your command to an encoder that supports the format you want to write to, which could be FFmpeg or some other encoder (for example, an alternative AAC or MP3 encoder). On Windows, the recommended EXE installer of FFmpeg includes an ffmpeg.exe which you can use for this purpose. On Mac, you can download a standalone "ffmpeg" binary if you search online.

Alternatively you can export to some additional formats supported by your build of FFmpeg by choosing Custom FFmpeg Export in the Export Audio Dialog.

back to top


Why do exported files not include Album Artist or BPM metadata, Album Art or Lyrics?

When you export a file, by default Metadata Editor pops up where you can add, delete or change embedded information about the file. Metadata is well supported by many audio formats, especially the ID3 tags used by MP3, but less well supported in WAV.

  • Metadata in imported MP2 and MP3 files (except for the default Metadata Editor tags "Artist Name", "Track Title", "Album Title", "Track Number", "Year", "Genre" and "Comments") will be exported as a "custom" ID3 frame. This means that exported custom tags such as "Album Artist", "BPM" or "Composer" will not be seen in Windows Media Player, Windows Explorer, iTunes or other software that ignores custom tags.
  • Relatively few audio applications or players are able to read WAV metadata produced by other applications, for example iTunes cannot do so. For iTunes, you can export to AIFF as an alternative lossless format with metadata support.
  • For WAV files, Audacity exports metadata in a RIFF INFO chunk for all seven default tags plus "Copyright" and "Software". It also exports all the entered tags as ID3 tags. Applications that can read ID3 tags in WAV files can read these tags.
  • Some audio formats supported by the optional FFmpeg library may not export complete metadata. See this table for more information.
  • For all formats, Audacity currently discards any existing lyrics or album art when exporting. You can copy the lyrics (or search for them online) then add them back to the exported file in your favorite media player. Extract the album art using a tag editor such as IDTE (or use Windows Media Player or iTunes to search online for the art) then add the art back to the exported file using your media player.

See also:

back to top


How do I import tracks from an audio CD?

Audacity cannot import tracks directly from an audio CD. You must use a separate application like Windows Media Player or iTunes\xc2\xae to extract (or "rip") CD tracks into a format that Audacity can read, like WAV or AIFF. Then you can import those WAV or AIFF files into Audacity.

The only exception is that on Mac computers with optical drives, CD tracks are mounted in Finder as AIFF files so can be imported directly into Audacity.

For more detail see the tutorial Tutorial - How to import CDs.

back to top

How do I save my recording on an audio CD?

After making a recording or editing a file in Audacity, follow these steps to save your work on an audio CD.

  1. Choose "WAV (Microsoft) signed 16-bit PCM" or "AIFF (Apple) signed 16-bit PCM" in the Export Audio Dialog "Save as type" dropdown menu to export to an audio file.
  2. Use any CD-burning software (iTunes® or Nero, for example) to burn this file to a CD. If you burn in a application that is also a media player, like iTunes® or Windows Media Player, you may need to drag the files for burning into a playlist or library. If in doubt, see the application's help files.

To make a disc you can play in all CD players, make sure to create a "music" or "audio" CD (not a "data" CD). Use CD-R discs, because some players cannot read CD-RW. You can burn only 74 minutes to an audio CD in most cases, but possibly up to 80 minutes depending on the CD-R. This is a limitation of the audio CD format.

Some CD software will burn only 16-bit, 44,100 Hz stereo audio files. If your CD recording software will not open your file, export the file again after choosing the following settings in Audacity:

  1. At the bottom of the Audacity window, set the Project Rate to 44,100 Hz.
  2. If your project does not already contain a stereo track, choose Tracks > Add New > Stereo Track. This will make Audacity export a stereo file.

See the Burning music files to a CD Tutorial for tips on CD burning with Windows Media Player or iTunes\xc2\xae and on burning "gapless" CDs or longer "data" CDs.

See also:

back to top

How can I split a long recording into multiple files or CD tracks?

Follow these steps to create a separate audio file for each song or segment of a long recording. This is particularly useful if you are creating an audio CD, since after burning each file to CD there will be a separate CD track for each song which you can skip to in the CD player.

  1. Click to place the cursor at the start of the first song.
  2. Choose Edit > Labels > Add Label at Selection. If you wish, you can type the name of the song in the label.
  3. Repeat steps 1 and 2 for each song.
  4. When you are finished, choose File > Export > Export Multiple.... When you click the "Export" button, Audacity will save each song as a separate file, using the format and location you choose.

Alternatively, Audacity can attempt to detect the silences between tracks and label them automatically. See the full instructions at Splitting a recording into separate tracks.

See also:

back to top

Why does Audacity warn about the name or nothing happens when I export or save?

Adding extensions and periods (dots) to names of exported audio files

On Windows when you export an audio file, Audacity will in most cases add a period (dot) and the appropriate (or most common) extension for your chosen format. So if you want to export a WAV file called "rhythms.wav", all you need to do is type "rhythms" (without quotes). If you type a desired period within the name itself, Audacity will usually add the final period and extension for you.

However Audacity will show a warning if you type a name ending with a period and characters that are the extension for any common media, document or image type and this extension is unexpected for your audio format. Press "Yes" in the warning if you really want to export with this file name, or "No" to return to the export dialog. This gives you the flexibility for example to export an M4A (AAC) (FFmpeg) file with M4B audiobook extension, if that is your explicit requirement.

More Windows examples (do not type the quotes in the examples given)
  • If you export as a WAV file and type "1.2 hours", the file will export as "1.2 hours.wav" with no warning.
  • If you export as an MP3 file and type "rhythms.jpg", Audacity will show a warning because JPG is an image format. You must type "rhythms.jpg.mp3" to produce a file with that name and extension.
  • If you export as an M4A (AAC) (FFmpeg) file and type "rhythms.mp4" or "rhythms.m4r" (denoting a ringtone in MP4 format), no warning will be shown because these are recognised extensions for the format.
  • If you export as an M4A (AAC) (FFmpeg) file and type "rhythms.mp3", a warning will be shown because you would export a file that Windows would see as an MP3 but contained MP4 audio.

On Mac and GNU/Linux if you export an audio file that has any period in the file name, Audacity will warn you (unless the implied extension is a recognised alternative extension for your chosen format). If you answer "Yes" to the warning, Audacity will not add the standard extension for the format. So if you need a period within the file name you must answer "No" to any warning, then add another period followed by the correct extension at the end of the name. Otherwise the file may not be playable.

Characters forbidden by the operating system

When exporting and when saving an Audacity project, Audacity may also warn you (or not respond correctly) if you type a file name that includes characters that are forbidden by the operating system.

Forbidden Characters:
On Windows, all of the following \  /  :  *  ?  "  <  >  |
On Mac OS X/macOS, colon only(1) :
On Linux, forward slash only /
(1) "/" in saved file names appears as a colon in Audacity.

Apart from operating system restrictions, Audacity has full support for printable Unicode characters in file names. However, if you want to send your file to someone else, use it on another operating system or make it available on the Internet, only use A to Z or a to z characters, whole numbers (0 to 9), underscore or hyphen-minus (or use the NUMPAD_SUBTRACT key). This will ensure the file name will always be compatible.

There may be additional restrictions such as maximum permitted characters in the path to the file, or some file names may be reserved for the operating system. Full details for Windows can be found here.

Showing file extensions on the computer: When you look at the file you saved or exported in Windows Explorer or Finder on Mac, you may only be able to see the file name itself (for example, "92.3 FM capture" ) and not the extension following it. This is not an Audacity bug, rather you need to set your operating system to show file extensions.
  • Windows: Open File Explorer, click the View tab then near the right end of the ribbon at the top, put a checkmark in "File name extensions".
  • macOS: In Finder, choose Finder > Preferences... then on the "Advanced" tab, enable "Show all file name extensions".


back to top

How can I backup my Audacity Projects?

Audacity has very robust crash recovery and in many cases can recover most or all of your work in the event of a power failure, computer crash or crash of Audacity itself. However it is a wise precaution to backup the project periodically to a separately named AUP3 file in case Audacity is unable to recover correctly. This also gives you the flexibility to reopen the project as it was at different points in time, because Audacity cannot restore a project's history once that project's session is closed.

The best way to make a copy of an already saved project is to use File > Save Project > Backup Project... and save to a new name. This makes a copy of the current project in its current state, leaving your current project open for continued working. See Managing Audacity Projects for more on how to work with Audacity project files.

Remember that computer hard drives can fail, destroying all data. Therefore regular backups should if possible be made to one or two devices other than the device the current project is stored on. For example, backups could be made to another internal drive on the computer, or ideally to an external USB drive or uploaded to an online (cloud) storage service.

If you have just made a recording it is strongly recommended to File > Export it immediately to WAV or AIFF (ideally to an external drive) as a safety copy before you start editing the project. If you are recording multi-track overdubs (recording tracks one after the other, such as drums followed by guitar followed by vocals), export each recorded track immediately you stop the recording.


back to top



How can I move an Audacity 3.x AUP3 project back to Audacity 2.x AUP format?

While projects created and Saved with Audacity 2.x.x or 1.3.x can be opened in Audacity 3.x.x the same is not true the other way around.

Once a project has been saved in the unitary AUP3 project file it can no longer be opened in earlier versions of Audacity.

There are a couple of workarounds:

  • Export the whole project as single WAV file and Import that WAV file into Audacity 2.x.x
  • Export each individual track as a WAV files using File > Export Multiple and then Import those into older Audacity versions.

See Moving AUP3 projects from Audacity 3.x to Audacity 2.x for more details.


back to top


>  Forward To: FAQ:MP3 export problems

<  Back to: FAQ:Playback

|< Index of Frequently Asked Questions